GE Z-Wave Plus 14291 stop working after some days

I have several GE switches on my house (over 10), but one of them keeps burning out after 20-30 days. The same one. I tried to replace it 4-5 times now, and it always do the same thing. It stop responding, then I go to the breaker, the breaker is disarmed and I tried to arm it again, it is not “armable”. I then replace the switch and everything start working again for several days/weeks. I am not sure what is going on with this particular circuit. Any ideas on how to troubleshoot it?

GE Z-Wave Plus Wireless Smart Lighting Control Smart Switch, On/Off, In-Wall, Includes White & Light Almond Paddles, Works with Amazon Alexa (Hub Required), 14291 - ttps://

I would find a good electrician if I were you, just to be safe, especially if you’re not familiar with debugging electrical stuff.

That doesn’t help. I already had two guys come in: First said that everything “was fine” and second said that I should just use a normal switch if the smart one was giving me issues, since it works normally with the “regular” switch.

Call GE/Jasco Support:

They just replace the unit. I was looking for some way to find what could be wrong.

I had a GE in wall Z-wave switch go out after a power outage. The power came back on and the switch started clicking about once a second while the light it controls also flashes along with the clicking. Switch does not respond to manual control and does not communicate with SmartThings hub.

JASCO sent a replacement switch, which worked for about a minute then also started clicking. Installed the replacement switch at a different location and it still clicks. I’m at a loss trying to figure out how a power outage caused this issue. Other GE switches are working fine.

Now looking for an alternative to the GE/JASCO decora style switches.