GE Z-Wave firmware differences? Old switches quit working but newer ones still work

I posted a while back when it appeared my entire set of Z-Wave switches was going down. After some back and forth with support and testing a lot of stuff myself, I think I’ve determined that the GE Z-Wave switches I bought a year ago aren’t working unless the hub is within 5 feet of it. I even removed them from SmartThings and tested with my old Wink hub getting the same results.

However at the same time, the 3 switches I’ve bought in the last month are working fine. They are on different floors of the house, and it doesn’t seem to matter where in the house the hub is.

It has me wondering if something is going on like the hub goes into one mode for the newer ones that isn’t compatible with the older ones, or some sort of interference is impacting the old ones but the newer firmware has a way to work around it? It all seems highly unlikely.

Can the firmware be updated on Z-Wave switches?

I’m sure that’s very frustrating!

Z wave itself is always supposed to be backwards compatible, but that doesn’t apply to the SmartThings cloud platform. They might make some changes that work better with one generation than another, you never know.

However, the first thing I would do is go into the IDE and make sure they are all using the same device type handler.

As far as updating the firmware on a Z wave device, it’s possible, but unfortunately not with SmartThings. Some devices can have firmware updates downloaded onto them, but those are typically only the ones that that can plug into a laptop. Not in wall switches.

How old are the switches? Are they still under warranty?

I bought most of them early this year, so if they have a year warranty, yes. Hopefully GE doesn’t need receipts.

What in the IDE is the device type handler? The column for “type?” If so they are all either “Dimmer Switch” or “Z-Wave Switch”

I believe the GE/Jasco’s are 2-year warranties. In my experience they do ask for proof of purchase to validate they’re still in warranty.

I believe the GE/Jasco’s are 2-year warranties. In my experience they do ask for proof of purchase to validate they’re still in warranty.

Thanks for the information. Good on the 2 year, but bummer on the receipt. I bought one on Amazon so I have that, but I’ll have to find out if Lowe’s will re-print 11 month old receipts. I probably threw most or all of them out after a couple of months.

I’m still thinking it’s basically impossible for 3 dimmers, one switch, and one fan control to all fail at the same time though. Additionally my Z-Wave front door lock also failed at the same time. It has to be some sort of interference, configuration, or communication issue.

The other weird thing is they all worked on Wink or Home Assistant with the Aeon Z-Wave stick for a long time, then all of the sudden Wink didn’t see anything. I thought the Z-Wave radio died in my Wink hub, so I bought the SmartThings hub and everything worked. Now a couple of months later that same set of switches all quits again?? I must be missing something, but I can’t think of anything in the house that would be on 900Mhz.

I agree it Certainly makes sense that if you lost a bunch of devices at once but on two different hubs then it does sound like a local interference.

Most commonly 900 MHz would be some of the old-style cordless phones or some baby monitors. But there are a lot of other things that can operate in the band, including ham radios, some smart meters, the Motorola canopy system, even some Internet channels although that’s rare.

Strength of signal will vary, so it could even be something that is a block away–particularly if it’s an illegal transmitter.

http://www.repeater-builder.com/tech-info/900mhz-frequencies-to-avoid.html

Tracking this kind of thing can be very difficult even with good equipment. Particularly if it’s intermittent signal.

Some field techs will use a blocking screen, even aluminum foil, to try and locate interference directionally. But even if you can tell what direction it’s coming from, you may not be able to locate the source.

So I know it’s a frustrating problem, I wish I had a better answer for you.