GE Motion Sensor stuck in purgatory

Hi, hoping to get some help with my GE Z wave plus motion sensor. I had to completely reset my hub last week and was able to re-add all my devices except my GE motion sensor. It’s weird, I successfully excluded it, tried to add the device, got the 3 second blue LED which means it connected, but it never shows up in my SmartThings app. The screen where it’s trying to add a device just stays up and it never finds the devices. I went to exclude the device again to try again and it successfully excluded, which leads me to believe it connected, but just didn’t show up in the app. It’s like the device thinks it’s connected, but Smartthings doesn’t think so. Anyone have any ideas?

are you using only z wave or zigbee aswell? also I’ve had the GE zwave plus motion sensor freeze for no reason at all before. had to return the two I bought. every other sensor zwave or zigbee has worked without freezing other than when needing a battery change/recharge. oh also maybe a factory reset is required before i can be repaired. i had a few zwave/zigbee outlets that have both in one that needed to be reset every time they were paired.

EDIT: just noticed your other topic. woo I also heard some subpar things about that dome sensor…tell me what is the layout of your devices? most of mine are near each other or the hub other than some sensors i have downstairs. maybe its possible you need to add a device that is able to “repeat” to make the mesh network the devices use a little more resposive or there at all past the pairing process.

I am only using z wave as far as I can tell. i’ve done the factory reset on the motion sensor already, no go.

i have my devices spread out through the house, with my in wall GE dimmers acting as repeaters for the z wave signal

Hmm I have both versions of ge wall dimmer haven’t had any problems with them other than the high pitch electric noise. Is your hub near a wireless router?