GE Link Bulb automation not working


(Chris) #1

Hi, I’ve just installed a few GE link bulbs, they are responding to the manual on/off command I’m sending through the ST app, but when I wanted the bulb to turn on and off in response to a motion sensor, the ST app shows that the command has been sent and the bulb has been turned on, but in fact the bulb never turned on. Is anyone having this issue?


(Chris) #2

It turns out that now the manual command doesn’t even work anymore. I reset the bulb and added it to ST again and now then automation is working. Does anyone know how to check and see if the bulb (or any other Zigbee / Z-wave device for that matter) is currently connected to ST or not so if it become disconnected again in the future I’ll know?


(Ray) #3

If it’s still possible to return these bulbs. Then do yourself a favour and return them. They are known for dropping off the network. You can replace them with the Phillips white lux bulbs which is more reliability. As for knowing if the device is still connected. Only way I can think of is if the device comes with other capabilities such as temperature, energy, or battery status which report back to the hub every so often. Maybe @JDRoberts knows more.


#4

You can do what field techs call a “wellness check” which is where you have something poll the device once a day or once a week and then you just manually review that report to see that everything is doing what you expect it to.

Don’t go crazy with this and poll many times a day. Zigbee and Z wave are just not intended for that. Too much polling will run down the battery on a battery powered device and create traffic jams on your network for all devices. Your lightbulb might miss a turn on or turn off command because it was busy answering the question of whether it was still connected! So do it sparingly. But a once a day wellness check should be fine.

Several community members have written their own smartapps to do this kind of wellness check. One of the most popular also has the most features, and can report on lightbulbs and other mains-powered devices as well. I especially like this one because instead of polling the device each time, it looks at the logs for the last recorded event rather than sending a new question to the device. That helps lighten the load on your network considerably.

For those who haven’t used custom code before, see the following FAQ. But it’s pretty simple. :sunglasses:


#5

I have 11 of these bulbs working perfectly, including 2 of the Daylight bulbs. They’re included in Routines, used via Smart Lighting automations, and controlled using Aeon minimotes.

To check to see how these are doing, look at your hub’s event log in the IDE. Look at the Last Activity column. It’s sorted from longest to shorted activity duration. A healthy bulb (not physically turned off) should look like this:

Those 2 bulbs in the red circle on the left are in lamps that sometimes will be used manually. In this situation and screenshot, the physical switch on the lamp is ON, but the bulb is OFF in ST. They’re not heavily used lamps, and they stay in that state pretty much all the time. If you look at the red circle to the right you can see that ST last contacted the bulb (polled) about 8 minutes ago.

That’s how you can see if your bulbs are behaving correctly in your ST environment, as well as any other zigbee device. In the same image you can see a wall outlet. There’s nothing plugged into it, and the only thing it does is act as a zigbee repeater. It also polled and was “awake” 8 minutes ago.

So how can you tell if a zigbee device craps out on you? Easy - if your zigbee device goes 2 or more hours within the “Last Activity” column, you have a problem.

I have a ton, and I mean a ton of zigbee devices, and all 95 of mine have last activity within an hour. As soon as one starts to drift into the 2 hour range, I investigate. Almost always it’s a range related issue, or interference with something. In fact, I can say with decent certainty that any issue I’ve had was range related. That’s why I’ve added the Iris smart plugs in key areas of my house, and with the $12.60 deal, I just bought more for the rest of the rooms in my house.

Referencing @JDRoberts’s post above mine, I don’t use any polling SmartApp, but I know some people do. I also have a “wellness check” app for when I don’t have the IDE super handy to use.


(Kevin) #6

I ended up creating device handlers for the GE Link Bulb and Cree Bulb that enable the device’s reporting so that I don’t have to externally poll them anymore.

They regularly update the lastPoll attribute which the Simple Device Viewer SmartApp uses for the Last Event time.


(Chris) #7

wow, thanks everyone for the detail response, great advice! I’m definitely going to check out the device viewer. I’m been doing automation with Insteon and just started with SmartThings a few days ago, so far loving the community!


(Chris) #8

I’m kind of new to this so I’m sorry if this is a stupid question. Are you saying that the Iris smart plugs are acting as a repeater for the Link Bulbs?


#9

Hi @Chris1981,

There are no stupid questions!

Yes, these Iris smart plugs act as repeaters for any zigbee device like the GE Link bulbs.


(Chris) #10

That’s amazing! I was worried about that since I’m moving from a tiny condo to a large house. Wasn’t sure if I’d run into problems with distance. I have 4 but I’m probably going to get more. Thanks!


(Chris) #11

@johnconstantelo and @krlaframboise I’ve followed your advise of installing Simple Device Viewer and also used custom device handler for the GE bulb (changed it to “My GE Link Bulb”), but the bulb is still losing connection daily. There is a motion sensor located less than 5 feet away from the bulb and that functions properly. The good news is that the bulb is able to connect again once it’s manually switched off and on once instead of having to reset it, but is there anything else I can do to fix the connection drop off problem?

Thanks!


(Kevin) #12

The Simple Device Viewer SmartApp is just a way to receive notifications when the bulb drops offline, it doesn’t prevent it front dropping offline. The device handler I post self polls so you shouldn’t have the polling feature in that SmartApp enabled.

Are you saying that when the bulb drops offline, the motion sensor still turns it on?

The link to the Device Handler I posted was called “Polling GE Link Bulb”, so did you rename it or use a different DH. I actually just posted an updated version of mine that polls every 2 hours instead of 10 minutes because polling too frequently can cause problems.

How far away is the bulb from your hub and are there any other powered zigbee devices between them?

If it’s the same bulb that’s constantly dropping offline, you may want to try factory resetting it.


(Chris) #13

@krlaframboise - two days in a row, the Simple Device Viewer was showing that the last activity of the bulb was from 5 ~ 7 hours ago when I checked them in the morning, and the bulb is not responding to manual on/off command or automation. I found the custom device handler I was referring to here Updated : GE Link Bulbs - FINALLY getting ON status after manually turning on!.

When the bulb drops offline, nothing will turn it on/off except the manual power switch (normal dumb switch). The motion sensor was able to sense motion, but the bulb doesn’t response to the ON command that’s triggered by the motion sensor. Since the motion sensor is battery powered, I take that it won’t act as a repeater for the signal?

The bulb is installed downstairs and the hub is installed on the 2nd floor, they do not have a direct line of sight and the distance is about 30 ~ 50 ft. The motion sensor is installed right next to the bulb less than 5 feet away, it’s a tiny bit closer to the hub. I also have open/close sensor installed outside of the house, further away from the hub, and it seems to work fine as well.

If it’s doing the same thing again in the next few days, I guess this bulb is going to the trash…


(Kevin) #14

I’m not saying it will solve the problem, but it reports every 2 hours so if the Simple Device Handler SmartApp shows a last event time of more than 2 hours, you’ll know that the bulb has stopped responding.

Edit: In the Simple Device Viewer SmartApp, make sure you have the Other Settings > Advanced Last Event Check setting enabled. Otherwise it will only pickup the last time that the bulb turned on or off.

Only powered devices can be repeaters. Are the other sensors that aren’t having problems zigbee or z-wave?

30-50’ on different floors without a line of sight seems like a lot, but I could be wrong. Can you add another bulb between the hub and the bulb that keeps dropping offline?


#15

If I were you I’d switch back to ST’s default. All my bulbs use the ST default instead of the one you linked to that was once mine. ST incorporated the work of many developers into theirs, and it works very well.

While the motion and open/close sensors work, it just may be that they do a better job dealing with a greater distance from the hub. If I were you, I’d buy one or two of the Iris/SmartThings Smart Outlets that you just plug in to any wall outlet. They are great zigbee repeaters, and will make a difference in the performance of your zigbee mesh network. I personally have 9 of them spread across the house just for this purpose.


(Chris) #16

@johnconstantelo are you saying even if I change the device type of the bulb back to the ST default type, the bulb will be able to connect back to the hub properly after it loses connection (turned off manually) for a few hours, and then manually turned off/on again by the dumb switch? Last time when it lost connection, I turned it off and on a few times and I still can’t send command to the bulb, maybe I was just being inpatient…

@krlaframboise I have Advanced Last Event Check enabled already, am I supposed to receive a notification telling me when the bulb stopped reporting for a few hours?

Thanks!


(Kevin) #17

If you want to receive notifications, you will need to specify the last event threshold in the Thresholds section and enable the last event notification in the Notifications section.

If the physical switch is off and you have the threshold set to 2 hours, you’ll receive a notification about 2 hours after someone turned off the light. The SmartApp has no way of knowing if the bulb dropped offline or if someone turned off the power, all it knows is that it hasn’t heard from the device in over 2 hours.


#18

Yes. ST’s default device type has been working perfectly for me, even when people manually turn off the lamps where the bulbs are placed. My daughters are notorious for doing this even though the minimote is on their nightstand. As soon as they’re turned back on, the state properly reflects in the app and you’ll see a “rejoin” event in the hub’s event log. I also have an Iris Smart Outlet in each room, and that helps.


(Kevin) #19

My first response to this was wrong, I was thinking of the Cree Bulb.

I’ve been doing some testing and even with my custom device handler for the GE Link bulb (the one you were previously using wasn’t mine), when the physical switch has been off for a while and I turn it on, the SmartApp shows that it’s been turned on within a couple of seconds and I can immediately turn it off.

You might want to try adding another zigbee device, like the iris smart plug @johnconstantelo mentioned, or even just another GE Link Bulb, between the bulb that’s not working and the hub.