GE Link Bulb not turning on and off manually

smartlighting

(Nick Beard) #1

Hello All

I have a GE Link Bulb that wont turn on or off using ST app. I do have it setup with multiple smartapps such as smartlighting and routines such as arrive home and good night. The smart apps and routines work perfectly but we cant manually control the light. Is there a way I can determine why this is happening?

I have been searching related posts and no one (to my recollection) at this point has automation working and not manual controls.

What information do you need from me to help this along?

Thoughts?


#2

I’m sure that’s very frustrating. :disappointed_relieved: You can contact support and see what they say.

https://support.smartthings.com/hc/en-us

What phone OS do you have (iOS, android, windows)?

And this is probably too obvious, but it tripped me up when I first started, so just to be sure, you are tapping on the icon on the far right of the device in the things list, right? (Not on the device name or on the icon on the left of the name.) For example, this is my list. To toggle guestroom table on I would have to tap on the “off” button to the right of “guestroom table.” This is different from many other home automation systems where you can tap the image icon to toggle a light. In SmartThings, you have to tap The specific action button, not the image icon.

It can be confusing because that same column is used for the status of a sensor. But for a light, that’s the action button as well as the status.


(Eric Brown) #3

I have had difficulty with the GE Link Bulbs as well. I installed one in my garage to act as a repeater for the presence sensor in my car and the tilt sensor on the garage door. The first bulb worked fine for a few weeks and would turn on and off appropriately with SmartApps or with the control button in the SmartThings app. However, after a few weeks the bulb stopped responding. I removed and re-paired the device multiple times, and turned off my hub to force a ZigBee network repair, but nothing seemed to work. I tried a second GE bulb and after about a month the same problem started to occur.

I contacted SmartThings support, and they indicated that the bulbs may have an old firmware version installed. Unfortunately there currently is no way to update Firmware on the GE Link bulbs through SmartThings. This is probably why the GE Link Bulbs are no longer on the list of SmartThings compatible products.

If you are using the bulbs indoors, then I would recommend switching over to the Cree connected bulbs. I’ve had pretty good success with them.

Return the GE Link Bulbs if you still can.


#4

Good point that GE Link bulbs have a known firmware problem that can cause them to disconnect from the network. That’s the reason they are not on the official “works with smartthings” list. I also replaced most of my GE links, although in my case it was with the $15 Hue whites.

That said, that particular firmware problem would not cause the bulb to be controllable from a routine when it was not controllable from the things list. It just wouldn’t be controllable at all. So I think the OP has probably run into something different.


(Nick Beard) #5

I thank you for all your responses. I am not entirely happy that the consensus is to return the bulbs. I have five throughout the house and three more as extras since they were on clearance. Now I know why. Well I decided to replace the troublesome bulb and the new one is working well now to all commands.

Not exactly the best solution for those that don’t have extra bulbs, but I cannot return these, so I have to deal with em. Next time ill go with the Samsung SmartThings Outlet. I just needed the dimmer option as a nightlight for my daughter’s room :confused:.

@JDRoberts. Thank you for the screen shot. I do press the button you are mentioning should be used. It just sticks on the “turning on” state and if you were to go into the thing’s page it would switch back to the previous state (nothing would change with the physical light, just the interface would say turning off/on and not change from there).


#6

But you could switch to a routine and the routine would turn the bulb on and off?

If that’s the case I would definitely contact support.


(Eric Brown) #7

I got mine because I wanted bright exterior lights that could be controlled and a powered ZigBee device to be a mesh network repeater.

The behavior you describe of the UI button saying “Turning on” or “Turning off” is the same behavior I encountered before contacting support. Sometimes my routine worked correctly, and sometimes the bulb would get stuck in an on state and stop responding to the app or the routine that was suppose to turn if off.

Fortunately I got mine on clearance for less than a standard exterior LED bulb, so it wasn’t a complete waste of money. After all the headaches the GE Link bulbs caused I can understand why they were on clearance. There is a long thread about problems with GE Link Bulb firmware.

If you have a dimmable LED bulb that you want to use as a nightlight, you could get a dimmable Z-wave plug-in module like the Aeon Labs Smart Dimmer 6. That would be a better option than the SmartThings Outlet, unless the majority of the devices on your network are Zigbee.

Currently it seems like there are fewer Zigbee than Z-wave devices on the list of compatible products. Outside of Samsung SmartThings devices, most of the Zigbee devices are different smart bulbs.