GE light switch Z-Wave device time

For years prior to ths week my GE light switch connected to my V2 Samsung Smartthings Hub was configured to turn off 10 minutes after switch was turned on.
Now coincidently (?) since the GE switch driver update of 02/15/22 the timer will not stay active. I can cofigure the switch to turn off after 10 minutes but then the switch actiivation slider shifts off and deactivates the timer.
Any help or insights on how to keep timer state active would be greatly appreciated!

What model switch? Which driver is it using?

If it is using the stock Edge driver from ST, I would recommend switching to this driver [ST Edge] Driver for GE/Jasco/Honeywell Z-Wave Switches, Dimmers, Fans, Outlets, and Plug-Ins from @philh30. Many people have better luck with their GE device behaviors with his driver.

1 Like

How were you doing that then?

Thank you for your quick response! I installed the driver you suggested, went into the device and selected the new driver, activated switch again, and after the prescribed interval (10 minutes) the light turned off, however the timer slider also switched off thus deactivating the timer for future events.
So I am back where I started.

Under the device I simply set the software slider to the right and set the interval. That is what I have tried now however after each action is processed the device slides the timer slider to the OFF position.

I was always under the impression that the Timer in the device panel was a one time event. I think you can accomplish what you are trying to do with a Routine that says:

If Light is off (precondition)
Light is turned on
Turn off
Delay this action 10 mins

1 Like

You are correct! I apparently misremembered how I set it up several years ago.
This past weekend all 21 of my GE Zwave switches and outlet devices and routines vanished from my Smartthings application. I spent Monday and Tuesday resetting everything only to have a Smartthings driver push Tuesday afternoon cause it all to crash. I got up Wednesday and all was functioing as it should.
I am reconstructing all my routines and scenes now that everything seems to be functioning.
Anyway, your solution worked! I am very grateful. Thank you!

1 Like