Routine "Auto Turn Off" doesn't work if I choose a "Customize" duration

I made a simple routine to turn on a GE z-wave outdoor outlet once a week and choose “Auto Turn Off” and “Customize” for the duration, setting it at 2 hours.

It would come on at the correct time but never shut off.

If I choose the preloaded 1 hour duration from the drop down it shuts off after 1 hour just fine.

Anybody else?

I’ve been having intermittent problems for about 3 weeks with auto turn off. I have a “I’m Back - Night” automation that turns on 4 lights when we arrive home and then turns them off after 2 minutes (at least that’s what the automation is setup to do). For several weeks now one or more of the lights (either smart bulbs or controlled via GE smart switches) will not turn off automatically. I don’t see many others having this issue so perhaps we need to reboot the hub or re-create the automation (assuming we are having the same problem that is). Will keep an eye on this thread.

So 2 minutes is also a “customized” time.

Try one of the preloaded times, 10 seconds, 1 minute, 10 minutes, or 1 hour. See if that works.

Hey there! @Jeff_H and @hoffmanchad1971, I’m sorry to hear that you are having issues with the ‘Auto-Off’ feature when setting up Routine Automations.

I’ve attempted to recreate the routine automation with an alert and was unable to replicate the symptoms when selecting a ‘preset’ or ‘custom’ time. It executed as expected and alerted me with a notification when the selected time arrived.

I would recommend completing that soft reboot of your hub to see if you still experience issues with customized times.

If the symptom persists, I would recommend creating a Support ticket and we’d be happy to look into your concerns further.

You can reach out directly to a support team in your area using the below information:

US: 1-866-813-2404
UK support 0333 0000333

I hope this message finds you well!


I’ve rebooted the hub. Hopefully that’s all it needed otherwise I’ll open a ticket as suggested. I’ll provide updates here as well.

BTW, @SamsungZell , how do you setup a notification when the lights turn off after the set amount of time? Also, will the “turn off” command show up in History?

@hoffmanchad1971, Notifications can be managed using the ‘Notify Someone’ in the action options for ‘then’. You have the option to notify via text message, push notification to specific members, or speaker announcement. I tested the Routine automation with all three types but only included the push notification in the screenshots below.

Additionally, you can indeed view the ‘on/off’ functions of your device in the History of the Smart Things Application. When you select history, please ensure that the device is selected for the history to display. If you have multiple devices, you can narrow down your results by selecting only the device you are inquiring about(the lights/switches).

Here are the screenshots of the automation:

I hope this message finds you well!


Last night I was finally able to test the “I’m Back - Night” automation after rebooting the hub and, it seems to be working again. I won’t say for sure until it’s worked 100% a few more times, however, since at least one of the lights was not turning off for a few weeks, fingers crossed that the glitch is resolved.

@Jeff_H , I never did change the 2-minute “custom” auto turn-off delay to a preset one. I’d try rebooting your hub also.

1 Like

I deleted the routine all together and recreated it. Today it worked OK.

1 Like