GE/Jasco outlet not responding


(Matt) #1

I installed a number of the GE outlets around the house last fall, A couple I had controlling my christmas tree during the holidays. Worked OK then. However I have one outlet that will not respond anymore. I’ve tried a zwave repair and got a bunch of errors, said it was complete but still not working. Since it’s hard wired and there are other things on that circuit I’d prefer not to turn that circuit off, not sure that would help in resetting it anyway. Any ideas?


(Matt) #2

Here is the report generated and my listing of devices. Some number in the Zwave repair screen do not match up with the device listing, confused.

the item not working is the one showing no activity in the 2nd screen shot, Device ID #13


(Ray) #3

Do a z-wave exclusion in the ST app and exclude the switch. Then go back into the device in the app and click the little gear on the top right corner and replace.


(Matt) #4

Thanks, tried that but nothing. Got frustrated and pulled the outlet out of the wall, disconnected the black power lead, pushed the button on the front a number of times to clear it, and reconnected, all is working now.

The thing that I found strange is the power on/off button on the front of the outlet would not respond either. Once I reset it, now it works as it should too.


(Ray) #5

I can relate to your frustration. I have 10 + Quirky outlets with this same problem weekly :astonished: only way is to power cycle.


(Michael) #6

Every now and then one of mine will misbehave too. I found that you can just turn off the breaker for a while and turn it back on and it will start working again.


(Matt) #7

Luckily this is the only one that is acting up–at this point. Got a few things like my DVR and other stuff on that circuit so I really don’t want to flip the breaker, but it might be easier in the future.


(Matt) #8

Just a quick update. Had another issue with a GE switch/dimmer, was not responding. Physically I could turn on and off, but Smartthings had no control. Instead of killing the circuit to reset it, I pulled the air gap switch on it and that reset it. Much better than killing the whole circuit.


(Eric Dryer) #9

I have the same issue. The funny thing is the Routines can still control the outlet and I can still change the LED setting. I believe it all started when they rolled out device health. I have gotten around the plug not responding be creating a virtual switch connected with a SmartApp that will control the function, but the device will not report or record the event.