GE Zigbee Dimmer Issue - Full on / off - Not dimming on and off

Hi everyone,

I had SmartThings at my old house and loved the dimmers. In my new house, I just installed a GE Zigbee dimmer (45857GE) but when I flip them on/off manually or via the app, they do not actually scale up to 100%, but rather just turn on like a normal on/off switch.

Is this by design? Anything I can change to fix it?


I don’t have “this” dimmer but I do have the other GE fan controller. I have read about these before. It says on/off and dimming. Are the bulbs you have installed dimmable? Not all led bulbs are.

On my fan controller. When you turn it on it returns to the last level. If you want higher you press and hold the up paddle. Lower would be same action on lower panel.
On/off is just a tap action.
I know you probably already knew all that. You didn’t really give much detail so I’m kinda shot gunning here.

I have both the Zigbee and the Z-Wave version of this dimmer, and from what I’ve read around the community, this is the way it is. Not sue that any Zigbee dimmer does the fade in/out, but I think others have said that the API doesn’t even exist to change the fade rate (as it does on Z-Wave dimmers).

1 Like

Thanks Barry.

Do you know of any Z-wave 3-way switches that can operate CFL and LED bulbs and gradually fade in/out? If I’m not mistaken, the z-wave version of this switch cannot.

Out of curiosity, is this a limitation of the switch itself? I feel as though a smart app could be written to fade the lights in/out gradually for when controlling via phone. But tapping the paddle wouldn’t behave that way.

I use the Z-Wave version of this switch to handle dimmable LEDs all over my house, with the fade in/out.

I don’t know what the limitation is for Zigbee, and I doubt that there is sufficient resolution of ST delays to get the same effect (I think the ZWave does the fade in less than a second or two)…


Are you able to get fade in and fade out when issuing a set level command? Or just on and off?

Bumping this old thread to see if anything new has come up. I got my Smartthings hub and immediately installed 4 of these switches (all 3-way). Only later did I realize that I would like for them to dim on and off and found the GitHub for “Enhanced-Dimmer-Switch”, which doesn’t work for the GE45857 (bummer). I have been searching for a while now and don’t see a solution for this particular switch.

Has anyone figured out a way to have them ramp up and down for regular on/off activity?

I would also be interested in this. I like the ramp-up that the zwave dimmers have. Definitely missing it with the Zigbee dimmers. And there’s no way to turn off the led.

Scratch that, it looks like jhamstead has put one together here! Anything like "Enhanced-Dimmer-Switch" for 45857GE zigbee switches?

1 Like