GE In-Wall Smart Outlet (GE 12721) Help!


(Joseph Fattizzi) #1

I just installed 4 GE In-Wall Smart Outlet (GE 12721) (Z-Wave) outlets. One of them is connected and working like a charm! The other three i cannot connect to the STH no matter what I try. I have tried excluding, repairing and moving my hub closer. Any suggestions?


(Eric) #2

what is an STH? Is this a lisp?

The hub signal may be occluded by interference from a close wireless router.

Sounds like the device(s) is already paired, perhaps by factory testing or previous owner. Did you run the device’s own exclude procedure? (in addition to excluding/general exclude). The specific device exclude procedure varies per device so you have to look it up.

That’s where I start - there is probably more exhaustive info coming.


(Joseph Fattizzi) #3

SmartThings Hub (STH)…

How do I used the devices own exclude procedure?


(Mark) #4

Z-wave operates on a different frequency than wifi, so that shouldn’t be an issue (Zigbee and wifi are both on 2.4GHz). It’s entirely possible that the devices aren’t able to pair because of issues with your Z-wave mesh network though.

Follow the instructions that came with the device, the section on Z-wave exclusion, or factory reset.


(Joseph Fattizzi) #5

THat is part of the problem, i dont know how to factory reset the device. I tried doing it according to the smartthings help document, but its still not working.


(Don) #6

I know it’s probably a dumb question, but are you sure they are wired correctly and have power / good neutral path? Maybe bad connection in the run or something? I know that’s not much help. I thought the plugs cleared themselves when you excluded them? could be wrong and probably are.


(Ben) #7

I have these switches throughout my house and yes, they can be a bugger to connect. This is how I’ve got them to connect:

With the switch in the off position, start the discovery process from the app.
Turn the light switch on and wait 5 seconds, then turn it off.
Wash, rinse and repeat (sometimes up to 20 cycles) until either it connects or you get pissed.

If the app doesn’t find the switch, make sure to scroll the app back to the Market Place and check to see if there is a device awaiting configuration. This should be listed at the top of the first page.

If the above doesn’t work, close out the app and completely log out of ST.
Log back into ST and repeat the above process again.

If this doesn’t work, give it a few hours (or a day) and try it again. Don’t ask me why, but this has worked for me when dealing with stubborn switches.

Out of all of my switches installed, I can only think of one, maybe two which haven’t been a struggle to connect.

Best of luck to you sir. Keep up the good fight, or return them as defective and try again.


(Jason "The Enabler" as deemed so by @Smart) #8

Dude, you’re luck sucks… I’ve got around 45 or 50 of these things… never had a problem. Except that time i put 4 in one box… and wired them wrong… long day there!


(Don) #9

I believe he (OP) said it was the wall outlets. No switch to toggle.


(Joseph Fattizzi) #10

Yes. they are outlets. I got two out of the three to work. There is no set way to get them to work, sometimes they do and sometimes they dont


(Ben) #11

[Punching self in the forehead mode ON]
Awe…what a moron am I? See what happens when you try to do something at oh-god-thirty o’clock in the morning after a 13 hour shift at work?

And here I was…all excited that I actually might be able to help someone and become a productive part of this community. :pensive:

Terribly sorry. Mods please feel free to delete my post and subtract one of my badges for being a pillock.


#12

Your advice to flip the switches applies to pushing the button on the outlets too … so you get to keep all your badges :wink:


(Don) #13

Yeah I just read that somewhere, believe it was a post on a Lowe’s iris forum. Possibly the manual on off button during the exclude step?


#14

For both the include and exclude step … works for me. I have eleven of these outlets and looking to add more — no problems with including them in my z-wave network. All you need to do is repeatedly push the manual button until ST finds it — or until you get pissed :smile:


(Jason "The Enabler" as deemed so by @Smart) #15

This thread just recommended me (after reading that it’s about outlets) that I have a bunch of these in the garage that I need to install…


(Bradley Baker) #16

I have two of these that use to work, I was able to remove them/exclude them, but when I add them back they come back as a generic “Z-Wave Wall Switch” and there is no “LED Light” option that use to delineate when the LED light would show. Also it doesnt respond to any commands.

From what I can tell these are suppose to be just like the Jesco wall outs in the Lights/Switches -> Jesco -> Outlets.

Is there something Im missing or not doing correctly?


(Michael) #17

Z-wave wall switch is the correct device type plus it runs local on a v2 hub. They moved the indicator light setting to the device preferences. Click the gear/sprocket on the upper right corner of the device to access it.


(Bradley Baker) #18

Yeah I know where it “usually” is suppose to be. One of my outlets doesnt have that option, just has the Name/Icon, its missing the “LED Status” options.

Also neither of them are responding to commands, this is after me removing them via the “general exclude” and adding them back.


(Joseph Fattizzi) #19

You just need to go into the IDE and switch the device type.


(Bradley Baker) #20

Ahh. Still doesnt make a difference, other than I now get the LED status option. The device still doesnt work and accept commands.

I try repairing the mesh and it fails on the two outlets.