Ge enbrighten 2nd gen paddle switch

Just bought one of these 2nd gen switches with “simplewire” and “quickfit”. I like the smaller size but the simplewire is gimicky. The problem is that I can’t get it to pair. I have done an exclusion as well as a reset (up up up down down down, led blinks 5 times) and re-pair many times. I also moved the hub to be right next to the switch and re-tried all the steps above. I don’t see anything in the log that looks odd. Any ideas?

If you have any custom DTHs in your IDE, republish them before trying to pair.

People have noted that the cloud seems to half forget they’re there while pairing and the system says hey I have something here that should match that device fingerprint and then can’t find it causing pairing to fail.

And if you’re in there republishing device handlers, you might as well run through the entire list.

Hi @finagleStar, which mobile app are you using to try and join the switch? If you’re using the new app (not Classic), don’t select GE/Jasco but instead select Other for the manufacturer list.

1 Like

Or hit the Scan button on the upper right of the page with list of manufacturers.

Interested because I have ordered two of these, plus one add-on for 3-way. I’m getting tired of trying to cram everything back into multi-gang boxes!

Yup, cool thanks for mentioning that!

I use classic. No custom dth. Ordered 1st gens;, these are going back to Amazon.

Well, I just got my set of the GE Enbrighten 2nd Gen dimmer plus add-on.

Not working to the point where I’m even ready to add to Z-wave.

My 3-way has line in one box, load in the other. It’s controlling four 8W LED can lights.

The 3-way wiring for the GE combo involves nutting the black traveler to load in the load-side box effectively turning it into a single-pole. Red traveler and neutral connect to the add-on switch.

Got it all wired up. When I switch on the primary, the LEDs come on super bright and flash off every couple of seconds. Dimmer doesn’t dim them at all.

Add-on and primary both switch the lights off, neither will dim them.

Stumped.

As a test, I replaced the GE Enbrighten primary with a Zooz ZEN26 switch (not dimmer). Left the traveler & load in the secondary box nutted together. Did not connect red traveler to the ZEN26.

Works perfectly as a single-pole switch.

I tried the GE dimmer same way, eliminating the 3-way and add-on. Still over-drives the LEDs and still will not dim.

Something not right with the Enbrighten 2nd Gen.

I’ve got one more of the GEs on the way. All three (2 dimmers and 1 add-on) are going back to Amazon.

Just to post both perspectives, i have a couple of the new simple wire Ge dimmers and they work.

They paired with no problem and work fine.

2 Likes

To be fair, none of the smart switches are compatible with every LED light.

The GE Enbrighten 2nd gen seems not to be compatible with the Ecosmart LED can lights we have all over the house. Zooz ZEN26 switches and ZEN27 dimmers work perfectly with these as do Leviton DZS15 switches and DZ6HD dimmers.

The Zooz ZEN26 switch isn’t working with some fixtures that have Kodak LED bulbs. I received a GE Enbrighten 2 switch that I’m going to try in its place tomorrow or Tuesday.

But I don’t have another spot for the Enbrighten dimmers so they’re going back.

Just to followup: GE Enbrighten 2nd Gen switch (not dimmer) successfully installed in place of a Zooz ZEN26.

Paired using new SmartThings app via the Scan button. It took me two tries, the switch doesn’t give any indication it’s in pairing mode.

This replacement fixed an issue with the current used by the ZEN26 when off causing some Kodak LED bulbs to glow dimly.

1 Like

One more followup on this.

The locator LED on the Enbrighten is about bright enough to read by!

Had to change its setting to “Never”

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.