Trouble pairing GE Smart Switch (Model 12727)

I installed a GE Smart Switch (Model 12727) in the garage tonight. The light switch works on its own, but I’m having a heck of a time pairing it to the Smart Things v2 hub.

I have a couple other things including a motions sensor that are further away from the hub than this switch, so I don’t think distance is a problem.

I put the hub into paring mode and the app just spins and spins – it never finds the switch. According to the instructions, all you have to do is turn the switch on and it should be available for pairing. Is there anything else I’m supposed to do? I’ve tried turning it on and then off, turning it on and holding the switch in the up position, turning it on and then pushing the switch up again and releasing it… I’ve tried a bunch of combos… what’s going on?

Thanks for looking.

Try the reset first, then connect. You will have to turn the light on/off to get it to pair.

I would do a general exclusion first (put the hub in exclusion and turn the switch on/ off). Then when you try to include it go to the GE section and select GE on off switch. I have about 30 of them and some are stubborn. Good luck!

I just installed three of these last week and none were just discovered with the broad discover devices tool without help. I had to actually add a specific GE switch under the lighting section and when narrowed down to the type of GE switch and then it was discovered. All three working great.

Will the exclusion process tell me it did something or do I just hit the “done” button after I toggle the light on and off? It never told me anything and it doesn’t appear to have fixed the problem.

If it was included by accident, it will tell you that the exclusion was successful. It’s ok if nothing was excluded. Now go to add, then select light and switches…then switches and dimmers…then GE… then GE on/off paddle switch. And then turn on/off, on/off with couple of seconds between actions…

Alright, I got it included! Here’s what I did (thanks @SBDOBRESCU)

  1. Perform the exclusion – put the hub in general exclusion mode and then turned the light switch on and off about three times; waiting about 10 seconds between each
  2. Go to the GE on/off paddle switch and add it – I had to flip the light on about 5 or six times (about 10 seconds between each attempt) before it found the switch, so patience is the name of the game, I guess.

Thanks a lot folks!


I had the exact same issue trying to add a GE 12727 toggle Z-Wave switch to my SmartThings Hub. I could not get my SmartThings Hub to discover the switch no matter how many times I turned it on and off and tried the Z-wave repair (which never finished on my hub). So I rebooted my Hub. Then what worked was to perform the Exclusion process (even though I had never added a Z-wave device) and then added the device using the specific Marketplace selection of a GE on/off paddle switch (Z-wave) option. I’m going to add another one that is slightly further away this weekend. The instructions really should indicate this…

Jason, your solution worked for me, as well. Was having trouble getting my GE 12727 switch to connect. Following your steps – basically, flipping the switch on/off multiple times (~6-10x) and it finally found it. Thanks!

An easy question. The GE 12727 switch should work without pairing with the hub or does it need to pair up first. I’m trying to install it and 1) the hub won’t find it and 2) the switch doesn’t work with the light as the old analog switch does. Any ideas?


Sounded like possible wrong wiring hookup. The switch doesn’t need the hub to manually work. Even with just line hot and neutral connected to the switch. You should hear a relay clicking when flipping the switch.

Thanks for the reply. This is an older levitron switch with only hot and line no neutral. Not a wiring guy, but thought it would be simple enough. The old switch works fine, btw.

Got it at least doing what a switch is suppose to do. It was the neutral wire. The switches in my home are 25 years old. Added the neutral and it at least works. Now for pairing.

Unfortunately you need neutral for the new GE smart switch to work. Possible it’s bundle behind the switch? If not then most likely the power coming into the light fixture first which only option left is micro relay module.

Switching your load and line wires may help. In my house the wires were the same color and switching them did the trick. They were reversed on the original switch but it didn’t affect operations being analog. You also have to tie into the white (neutral) wire to use the 12727 switch. For those not electrically versed, do not use the tiny aluminum wire that’s included as that’s for an Add-on switch if you plan to use one. Buy a small length of copper residential wiring and cut to size. Make sure you have some wire nuts handy of multiple sizes as you could tie to a few or several white wires at once.

Well…This (GE 12727) toggle switch w/ the (GE 12728) add-on works manually so that part is nice. But…I can not get it to connect by doing the general search or the manual search by choosing the brand and then which style. I did what everyone advised by excluding it (nothing seemed to happen when it tried this) and then adding it again. Flipping the switch on/off up to 15 times w/ 10 seconds in between did not work. Going to bed now. Will try again tomorrow I guess.

I had one of my switches stop responding last week. It took me about an hour and a half of repeated replace , general z-wave exclusions and attempting to reconnect before it was finally successful. No reason at all why GE could not have had it so the LED would blink or something to indicate its state. When they work right they are among the easiest devices to set up, but when they don’t it is an absolute nightmare.

In the end I wound up putting my old Securifi A+ hub into general exclusion, popping the air gap and pressing on/ off/ /on a few times. Then having ST search for it. After about the third or fourth try it finally connected. I am pretty sure my neighbors to the back were less than thrilled I was flashing the back spot lights on/off from 11:45pm- 1:20 am trying to get it reincluded.

As it turns out I had to move the SmartHub to my wifi extender that is upstairs. I guess 25 feet away is too far a way for it to connect. When it was moved to 10 feet away it connected right away. My house is not that large (1950 sqft), what do you guys do if you have a large house?

Thanks for this. To exclude this switch Smartthings says “consult manufacturer’s instructions” and the GE instructions say “consult hub’s instructions”. Endless loop…

What a mess!

I noticed that there is an “LED” but I have not been able to ever get it to light up. Not that I really have a desire to, but I just thought that it was strange that there was a setting for something that wasn’t included.

PS - I have two of these sytle switches GE switches (without an air gap) and neither of them seem to have functioning LEDs, although they do seem to work otherwise, for the most part.