GE Smart Dimmer when turned on, default to full brightness

I have a Smarththings v2 hub and a bunch of GE Z-Wave In-Wall Smart Dimmer (Toggle) 12729 switches. I find it annoying that I can’t set them to default to full brightness when I tap the switch on. The previous evening I may have them dimmed to 20% for a calming effect, then the next morning when I come out and hit the switch, they return to the 20% but I would like them to have their dim level reset to 100. I’ve searched and found “Dimmer Switch with Reset” by bravenel but I can’t get it to work.

Can anyone steer me in the right direction?

Smart lighting app can do this

1 Like

Smart lights is close, but not quite what I’m looking for. The brightness doesn’t change until 5-7 seconds after I’ve turned on the light.

I’m looking for a way preset the dim level (every time the switch state is off, or on routine like “good morning”) before the switch is turned on.

This has been asked a few times and does not exist. The switch will always default to previous setting levels, which I prefer since in the living room I like my lights always around 40%.

I think I found a way in Core, still need testing and there is a risk of light flash during setting change. I ran through 2-3 tests and I did not see it.

First create a piston to Turn off the lights with a trigger of the time window you want it to execute. Ie 5:27am-5:29am

Then create a piston to the dim level you want with a trigger of time you want it to execute (maybe routine, but you have to deal with the time window above). Make another action in this piston to execute the Piston above.

Not happy with having a trigger in piston #1 but its a start to solving this issue. Hopefully this made sense.

Edit: can probably make it smarter using a variable. I will play around with this and post a better explanation once I know.


Thought about this some more and I am wondering if @ady624 can add this functionality into Core.

Can you add a SetLevel then off option to a dimmer? It would simplify the Piston setup and this has been asked for a couple times.

I can probably add it to Core as a PR, but will take me longer. :rolling_eyes:


you should be able to do this in CoRE, use “when (switch) changes to” “on” not “when switch is on” and make it set level to 100, that way you can dim it if you’d like, you could also set time windows (7am-sunset or sunset-7am) for different pistons and have multiple levels depending on time of day, you can also make these pistons only act to the physical switch.

This is my first crack at using CoRE. I’ve got it installed in my Hub IDE, but I have no clue what piston(s) I should be using. I’m trying to familiarize myself using the wiki, but if you could post steps a first-timer can understand it would be much appreciated.

There is a solid delay if you do that. 3-5+ seconds.

Most people have been asking for the ability to preset dim levels. Looked over the Core code and I think I can add the functionality. Will give it a shot.

As for pistons usually just stick with Basic

Eagerly watching this topic :). Just put a toggle in our bathroom which currently has CFL bulbs so I want it to default to 0 or 100. It was dimmed to 1 yesterday so the family thought it was broke. I think I saw a DH that can change the ramp, maybe it can do this as well.

That is my DH. Spent way too much of my life trying to get the GE Dimmers to do these things. I do feel Core has potential.

This is untested in CoRE, I also set the interaction to Physical.

● Room Light switch changes to on
Using Room Light…
► Set level to 100%

Edit: I had to remove the Physical interaction part for my light, it probably didn’t support it. Also, the piston will react only as fast as the piston receives information regarding the subscribed event.

1 Like

This does the exact same thing as the Smart Lighting screenshot I posted above.

Played around with this tonight. Core can setLevel and turn off (if you disabled Task Overrides in the Piston)

Problem is about 90% of the time you get a 1/20th of a second light flash. Even the test I did last night which was working is now showing a flash of the light, so any latency is an issue (and there is always latency).

I have done this for diming a lamp in the house, it’s noticeable but it happens almost immediately

@desertblade how can I know when CoRE has been updated to include the “SetLevel then off option” you requested?

Or if the functionality already exists, could you list step by step how to set up it up?

You could always try and set the level to 0 when turning off. When a light is turned off with set level 0 it will default to 100% when turned back on.

Not sure if you could do that in CoRE:

When switch changes to off
  Set switch level 0

It may loop too.

No need to change, you can program Core to have 2 actions. One to Set level, then the next to turn off.

You have to change Task Override to None on both actions, so they won’t cancel each other out.

I just needed more time to think through it. @ady624 really has done a fine job with Core.

Not having used CoRE before, I’m getting hung up on the easiest of things. How do I select the state of a switch? The “changes to” only gives me numerical options. Typing a 0 had no effect.

Piston mode: basic
If {Hallway Lights} changes to ******
Then set level to 100%
Then turn off

Also, do I need to change the device type of my dimmer or can I leave it at the default of “Z-Wave Dimmer Switch Generic”

Default Handler should be fine.

Instead of using Dimmer use switch (assuming you want to trigger on the off event)

Doh! “Switch” gives me the options I was looking for.

So if my trigger is a state of “off”, and the last event is to change the switch off, how do I keep it from looping? Is there a trick in CoRE I don’t know about?

In the meantime I have the trigger to be 4:15 AM every morning to evade looping.