GE Dimmer Switch doesn't change status

I recently installed my first z-wave dimmer switch (GE 12724) and I can control it with the app and with Echo but the status on the app (and IDE) stopped changing. When I try to turn it on in the app, it stays for a long time with the “Turning ON” message and then it returns to off status, even though the switch successfully turned on.

This is what I see on the log:

Here is the status:

Even if I physically turn it on, the state does not change. It seems like it was working this morning:

I am new to SmartThings so just wondering if this is normal hiccup and how to fix it. I already tried rebooting but it didn’t help.

Any ideas are appreciated.

I had this issue right after the recent update. For some reason, things got back to normal after I rebooted the hub. Taking power and batteries out and let it sit offline for about an hour. Mayne I just got lucky, but it’s worth giving it a try.

Thanks but I already removed the batteries and reboot but it didn’t help.

Here is what I’ve tried so far, with no resolution:

  1. Removed Batteries and Reboot
  2. Ran Utilities->Repair Z-Wave network
  3. Turned off power to switch

The device status currently says INACTIVE. I am not sure if that is correct or not.

Have you tried excluding the switch and re-pairing it?

1 Like

No, I have not. Thanks for the suggestion, I will try that.

Is messages coming from or to the switch in live logging? I had some devices that were non responsive and had to re-add them recently. May have been dropped from the Mesh network.

Live logging shows no message. But the devices turns on and off fine with the app request. Even with Amazon Echo I can turn it on and off with no problem.

Just checked my IDE and all my switches are inactive. Under list events it has all the state changes.

That’s good to know. I will try excluding and re-pairing tonight when I get home. I no longer see the events for the physical on and off. What got me puzzled is that the switch still turns on and off with the app (or in the physical switch), just the status never updates.

Another strange thing is that yesterday I saw several entries of type DEVICE /physical when nobody was home. I don’t know if those entries caused the switch to stop updating the status.

I have the physical commands but only when I press the button.

I wouldn’t worry about the status of inactive, I bet it goes to active status for seconds while it receives or transmits. looking at the Status for my devices there is no rhyme or reason.

I tried to exclude the device from the android app, and after I click delete I see “Exclusion Mode Active” but then then nothing happens. I tried double tapping the switch up and double tapping down and nothing happens. The app remains in “exclusion mode active”. :disappointed_relieved:

I had an issue with a GE switch after a power outage. I had previously done the reboot, battery-removal, have a beer, spin in a chair, and then wait for things to magically get better earlier in the day. For this instance, here is what I did:

  1. Confirmed the switch wasn’t being activated in the application
  2. Attempted exclude mode with the hub/app. It turns out there was nothing to exclude, as the switch after the electrical outage had somehow removed itself.
  3. Put the hub in ‘connect new device’
  4. Pressed the GE switch once back on…
  5. It paired and has been working since.

Right now, I’d recommend force-killing the application and using the IDE to first do a z-wave repair (you can also use the IDE for exclusion of the app is being buggy). If that doesn’t work, try the steps above. You may not have to exclude and repairing may work. Good luck.

I’m going to jump into this thread so as to not start another thread about the same thing.

I noticed today that some of my lights weren’t working like they were supposed to. To be precise, I have 3 GE Z-wave switches that control my front porch lights in 3 different groups (I have a lot of lights outside).

What happened is that I noticed that only 2 of the 3 groups were turning on when I was doing some testing in Rule Machine. (The app had nothing to do with this) I started checking things out and found that one of the switches was not responding. Unfortunately I was at work and on the road in 3 different states today.

When I got home I checked out the lights in the App. The one group of lights was not on when I got home and did not respond to my presence sensor arrival.

This is what I did:

1 - rebooted hub. This did not fix it.
2 - ran z-wave repair. This told me that I actually had 2 switches down.
3 - ran z-wave repair again… no joy.
4 - did a forum search. Read something about running the repair several times.
5 - ran z-wave repair again… x 10. I was really pissed about this time.
**** 1a - When the hub came back online it said it was “online and updating!” I thought oh crap! there goes everything working good!
6 - ran another forum search. Really started preparing myself to exclude the switches.
7 - took the switch out of all of the smart apps
8 - ran exclude on the switch.
9 - damn app removed the wrong damn switch! and deleted the smart apps!
9a - now I’m pissed
10 - finally got the damn switch gone.
11 - readded both switches.
12 - remade the smart apps.
13 - ran another z-wave repair. SUC-freakin-CESS!!!
14 - now I’m wondering what the hell that “update” was all about.

Oh, and where in the hell did the z-wave replace option go in the device preferences? Now there is only REMOVE… big step backwards!

So, does anyone have any idea why this happens?

1 Like

I honestly have never seen the ‘replace’ option on my app. Whenever I’ve had an issue, I’ve always re-added the whole dang configuration. Based on what I’ve seen in terms of release management and testing, I feel better about doing a complete remove instead of ‘replace.’

The only step you forgot was the beer.

I have had a similar issue with a GE z-wave switch, and I just disconnected the power, waited a while, and re included it. For some reason I did not have to do the exclusion.

Yeah it was there, I’ve used it a couple of times when changing plug in modules. I didn’t want to redo all of the apps so I just replaced the module… But the option is gone now.

Next time I’ll try the power disconnect.

It’s still there for me. iOS version 2.05 of the ST app.

Hopefully I can use it because I have at least one GE Switch that recently dropped off my zwave network too. No events at all in ST even though it gets used multiple times a day manually.

What happened??

I have no idea what happened. I know my hub got an update last night.

I tried a force delete and it got removed. I was then able to re-add it. but my issues are still the same. I can control the switch with the app but it still doesn’t update the state. :disappointed_relieved:

I think I found the issue, it turned out to be a range issue. The switch is downstairs and the hub is upstairs. I brought the hub downstairs within ten feet from the switch and it updates the state correctly. If I take it upstairs then it does not update the state, but still turns on and off. Upstairs is not really that far, maybe 25 feet.
This is my only zwave device so not sure if the range improves as I add more.