GE 12727 not turning on light

But if the red lead was line voltage then you would have had 120 on it the whole time. So I doubt that’s line. Just not sure it’s load either.

Are you sure there’s not another switch red wire is usually a traveler to another switch.

1 Like

I would double check the wiring. When I see a single pole circuit with red, white and black wires. That means it’s also Sharing the circuit with other system. The easiest way to check line and neutral is to disconnect all the wiring from the switch and do your measurements. Use your ground as a reference point for measuring instead of neutral for finding line hot. Once you find your line hot, remove your light bulb and find your neutral incase it’s coming from the light fixture.
You don’t need load to test your smart switch. So leave the load disconnected and check your switch. You will hear the relay clicking when flipping the switch. You should be able to pair it to ST as well. Once that’s done. Hook up your load.


Thanks for chiming in. I suspect something is up too.

Same. Just from looking at the pics, I suspected a 3-way situation, even if the OP isn’t aware of it. This point was already mentioned, so I assumed OP would know best.

So somehow the bulb blew in all of that. Had to climb up15 feet and swap it out. Now the switch works as a switch, but SmartThings isn’t finding it on the network. What’s the range on this thing?

How far away is the hub? Also in my limited experience it takes a few times for the hub to find the device.

Read this post #22 in this topic. It explains how to get them to pair / connect to a hub.

1 Like

I’m about 75 feet away from hub.

Those I tructions didn’t seem to do it. Tried manually adding as well.

Can you put your hub on a long cat5 cable to get it closer? As a test to eliminate distance.

Or possibly get ahold of support, maybe they can see if it’s trying to join or not?

There’s probably someplace you can look in the IDE for clues, I’m just not experienced enough to point you in the right direction.

Finally got the 100’ cat5 cable and the time to try it out. Worked great! Picked the switch right up, got it added and re-named, etc. now I’m keeping the 100’ cable attached to the hub and I’ll use it to run the hub out to add more devices in the future.

Thanks to everyone for the help.


Grats!! Glad you got that worked out.

Looks like I spoke too soon. Brought the hub back inside, and now the app keeps saying the hub is offline. It will control the devices inside the house but not the switch in the shop.

When I had the hub in the shop it controlled the new switch just fine, but back in the house it’s not reaching.

Is the switch connecting to the hub directly or do all the devices connect to the hub via wifi?

The hub does not control GE switches via WiFi.
It uses Zwave or Zigbee. The hub has no WiFi in it.

Your switch is out of range of the hub since it’s in your shop.

1 Like

What’s odd is that one of the other devices is further away, through 5 drywall partitions, and it picks up fine. I suppose I’ll have to start researching and selecting a booster/extender.

Possibly do a Zwave Repair?

I’m shot gunning here!

Possibly a faulty switch? Radio wise?