Garage Door Opener is non-responsive with status stuck on "Opening"


I’ve got a Linear GoControl Garage Door Opener that has been working fine for a while now. This past weekend I went to close it through my smartthings app and saw that it was stuck on “opening”. I can use it with the physical garage door button but going through the app is non-responsive. I tried my wife’s phone and it’s the same thing.

Looking at the ide page it shows that it is online and here is the current state:

  • contact: open
  • door: opening
  • checkInterval: 1920

I’m not sure what the problem is and I’m looking for suggestions. TIA

unplug it and plug back in. It should go to unknown and then cycle the door to get it synced back up.

1 Like

That worked! Thanks.

I have the identical problem, but the fix didn’t work for me. Any other ideas short of deleting the device and recreating it?

Try changing it to the default device handler.

I had the same issue with Iris opener over the weekend. Finally changed the battery in the tilt sensor, even though status showed battery OK, and re-paired the opener. Status went to unknown for less that a minute, then to closed and has been working fine since then.

For me, power cycling the garage door sensor worked. You could try that and also re-searching for it in case that helps, too.

Re-pairing the sensor finally fixed the problem. Now I have to put back all its connections to smart apps. Sigh… Makes me wish I did more documenting setup.

1 Like