Linear GD00Z-4 Garage Door Opener - stuck on "Closing" and now "Unknown"?


I purchased the Linear GD00Z-4 Garage Door Opener device last year and managed to get it to work flawlessly.

Yesterday, out of the blue, the garage door was stuck on “Closing” when the door itself was fully closed. I could not open the garage door, but I could close it. ST would correctly sense “Open” when the garage was open but it never say “Closed”, always “Closing”.

After researching, it seemed like a problem with the included tilt sensor…

  1. I re-paired the device (hold button for 7 seconds until beep). Nothing changed.
  2. I replaced the battery in the tilt sensor, twice. Nothing changed.
  3. Removed and re-paired device to SmartThings hub twice. Status is stuck on unknown, despite manually opening/closing the door several times.

I am thinking of buying this: Ecolink Z-Wave Plus Garage Tilt Sensor to replace the included tilt sensor.

Thoughts? Advice?

Have you tried running z-wave repair?

Yes I have. I tried once before I replaced the battery and re-paired.

After removing the device/re-adding to ST hub, I got an error saying it could not re-route device [03].

If you refresh the device after closing does the status change to closed, or remain as “closing”?

Tried refreshing, no avail.
The refresh button is almost useless.

I’m starting to think that my tilt sensor is faulty and/or not calibrating itself. It still shows “Unknown”.
I have turned off the power, unplugged the unit, manually operated garage door.

It just suddenly stopped work… is there any way to replace the tilt sensor?

Replace battery and open and close your door a few times with the actual opener to calibrate.

Definitely sounds like a problem with the tilt sensor. You have to use the proprietary sensor with it, so the z-wave version won’t work. Here’s the proprietary model

Thanks man!
I actually just ordered a brand new one…

But I’ll order this one too and see if the one you linked will work. If so, I’ll just return the new one!

check out the review on Amazon that has instructions on how to pair it to the opener.

[UPDATE] So I bought a brand new Linear GD00Z-4 Garage Door Opener and everything worked perfectly for the first three days.

Now, all of a sudden the sensor is stuck on “Open” and won’t receive any commands. I perform a Z-Wave repair and it says:

“Network repair for Garage Door [13]. Could not assign new route.”
“Network repair for Garage Door [13]. Could not delete old routes.”
“Network repair for Garage Door [13]. Could not update neighbors.”

How should I fix this?