Frient Smart Cable

Hi All
I;m after some help. Have any of you used the smart cable from frient ( Smart Cable - Zigbee energy monitor and home automation - frient ). i can get this to connect to the smartthings hub and app, but it shows as a remote. you are supposed to be able to use it as a switch ( turn on and off ) but on the app there is no option shown for this. my hub is the samsung V2, is it possible the hub is not compatable for the smart cable. any help would be fab.

Many thanks

Tagging @RBoy

Could you go into the IDE and edit the device to change the Type field to “Zigbee Switch”? It sounds like the fingerprint did not get picked up properly.

thanks for your reply, i’ve had it working but i have no idea what i did. it did show the device what i called Monty under a zigbee switch. but i also saw a device called Mont2 under "child switch health " . this was displayed as a seperate device but also it was displayed in the Monty device under In Use By. i’ve not got a clue. hope that makes sence

We’re helping frient with integrating many of their products. For this one you should contact frient directly and let them know that you would like to use it with SmartThings

Hi There, already sent them an e-mail, but had no reply yet. it does say that this smart sable does work with smartthings

Are they falsely claiming that the device is certified for SmartThings? It simply doesn’t do anything…

What does this mean? I can’t see any pages like what you are describing…

I think it would work if you could make it see the Frient Cable as the Freint Plug instead…

Have you logged into the IDE before (

I forked the SmartThings repository and logged in here:

My hub has suddenly appeared now on that site…

No Frient devices are listed in the IDE so I tried selecting ‘Zigbee Metering Plug’. It is correct in the app now but still doesn’t do anything… So confused as to what Frient have done wrong with this product…

Any ideas?

I just got a frient Smart Cable and can’t get SmartThings to see at all it in a device scan. If I could just get it to work as a simple switch, that would be enough for now. Has anyone made any progress with this device?

No, I just keep buying the product then returning it as ‘faulty’. The box says it works with SmartThings but it definitely doesn’t. Neither SmartThings or Frient seem to care that they are illegally marketing a product and using the SmartThings trademark.

Hi all, sorry for the late reply. I have got this working just as a switch, frient even gave me the code for it , again did not work. to get it work as a switch

1, just set it up the instructions say

2 go to the and log in

3 find the frient device and click on it

4 select edit

5 under type look for IOT8-Z , press update

6 at the bottom of the device details you will see " Child Devices " select one of these and remember the number

7 on your phone/tablet go to smartthings ( it will go crazy as it adds the child switches )

8 you should see Z WAVE REMOTE numbered 1 -8 and one with no number by it

9 the number you remembered 6 , delete all the other numbers expect the one from step 6, this will be used to controll the switch ( you can rename this ) and do not delete the Z-Wave remote with no number

10 that should be it

The Z-Wave remote with no number by it i created a room " DO NOT DELETE " and put it in their cause if you delete this the switch will not work.

I think that’s it; this will only work as a switch and not a energy monitor. There might be a better way but this was the first way I found to make it work

Please use instead of the URL you posted. That link may lead to problems for some users as it would not be sending them to their appropriate SHARD :slight_smile:

Thanks for that