SmartThings Community

Force non-secure join for Fibaro Dimmer 2, won't respond to directly associated remote

fibaro

#1

I installed a Fibaro Dimmer 2 to control my kitchen lights where I only have line and load, no neutral wire. I put in the Fibaro Dimmer 2 along with a 3-position single-pole double-throw momentary switch. It works great with no buzzing (unlike the Lutron Caseta which buzzed terribly).

I need to install a second auxiliary switch or remote for the kitchen lights in another location where I do not have uninterrupted power. I bought two devices to test as remotes for the Fibaro Dimmer 2. I bought the Cooper Aspire RF9500 battery operated switch/dimmer remote, and I also bought the battery powered GoControl/Linear WA00Z-1 Z-Wave Scene-Controller Wall Switch. My plan is to use whichever one performs best. (I hardwired the box where the old 3-way switch had been with the incoming line and two traveler wires. I hardwired the line to one of the travelers and it continues on to the box with the Fibaro Dimmer 2 switch. The other traveler is not connected to anything. Since that line is switched downstream by the Dimmer 2 and there is no neutral return wire, I’m unable to use any mains-powered zwave devices in this location.)

I am using a SmartThings Hub and connected the Fibaro Dimmer 2 easily. I notice that the Dimmer 2 is using a secure z-wave connection to SmartThings. Using either of the battery-operated remotes, I have managed to get them to control the Dimmer 2 via SmartApps managed by the hub, but they usually exhibit 2-5 seconds of lag and 20% of the time button clicks don’t result in a response. WAF is at unacceptable levels. I need a better solution.

Both of these remotes can also directly control other devices via Direct Association. The RF9500 unit uses standard Z-Wave protocol and directly associates to other devices through Group 1. The WA00Z-1 uses Z-Wave Plus and directly associates via Group 2. In testing, I successfully associated both units with other Z-Wave dimmers and switches in my house. Pressing the buttons turns on/off the associated switches. Holding the dimmer buttons dim the associated switches. Performance is fast and reliable and bypasses the hub.

When I associate either device with the Fibaro Dimmer 2, nothing happens. I notice that my remotes as well as all of the other Z-Wave switches in my house are attached to the SmartThings hub without security, but the Fibaro Dimmer 2 has a secure connection. I believe when it is securely attached that it ignores all commands from non-secure devices. How can I get the Dimmer 2 to respond to non-secure commands from other devices?

Can I force the Dimmer 2 to connect to SmartThings in a non-secure manner? Is there a method to force this via SmartThings or via a setting on the Dimmer 2 upon initial join? If I can do this, then I believe the Dimmer 2 will respond to the commands from my remote switches.

I also see that the Fibaro Dimmer 2 has Z-Wave device parameter #27 that can be changed to allow either secure or non-secure commands to be issued to Association Groups. The default value of 15 sends secure commands to all groups (2-5) and the value of 0 sends non-secure commands to all groups (2-5). But this only applies to outgoing commands to groups that the Dimmer 2 would directly control, and doesn’t affect whether the Dimmer 2 responds to incoming non-secure commands from other devices, right?

Any help would be greatly appreciated.


#2

I’ve not tried this, but I’ve seen reference that if the Dimmer 2 initially joins the ST hub via an intermediate point in the mesh network, then it won’t join in a secure manner. Might be worth a try to move it to another part of your house where there’s a repeater nearby and connect it the hub from there?


#3

Thanks for that suggestion. Maybe I’ll run an extension cord out the other side of the house and wire the Dimmer 2 right onto the end of that. That would ensure I have other devices between it and the hub and enough distance to force a double hop. Seems easier than opening up a random wall box temporarily. I’ll move it back to its intended switch box after the join. I’ll report back if that works. It still would be nice to control whether a join is secure or not via a setting on either the hub or the device, though.


#4

Also paging @RobinWinbourne who has extensive experience of the Dimmer 2.


(Robin) #5

If you force a non-secure connection (by ensuring a mesh hop as noted above) then the best handler (from @zcapr17) will not work.

I believe an older handler by @hajar might still work though, as it tests for security type and sends appropriate commands.

I don’t think security makes a difference though… I’m fairly sure I’ve associated secure and non-secure devices in the past.

Key (I think) is only to associate from one device (not double up by doing it from both devices)… @zcapr17’s Fibaro handler has association built into the handler, is this what you are trying?


#6

Just wanted to reply here that I never did get any of the battery operated remote switches to directly control the Fibaro Dimmer 2 by adding the dimmer to the remote’s direct association groups. So I reverted to routing things through Smartthings, which works ok, but there is often a lag of a few seconds.

I did test installing a second Fibaro Dimmer 2 unit in an adjacent room, and I could get each of the Fibaro dimmers to control each other through direct association. I used @zcapr17’s zwave tweaker to set association group parameters on all devices. I ran one dimmer outside my house on an extension cord far from my smartthings hub and forced it to attach to the hub in non-secure mode. If I had one Fibaro Dimmer 2 attached securely and one non-securely, they couldn’t control the other one through direct association. If they attached to the hub in the same way, then they could control and dim each other directly. The battery operated remotes I was testing could never control any of the Fibaro Dimmer 2’s via direct association.

Likely this could be accomplished with local execution with a different type of zwave hub besides smartthings, but I didn’t want to deal with learning that.