Fibaro Dimmer 2 - Control of Z-wave devices (2021)

Hi,

I had my system running nicely on the old smartthing app, but have been struggling since switching to the new app. I have 3x Fibaro Dimmer 2’s, one controlling a main light with an additional switch. The other two control seperate lamps in the room. Before, I used the settings in the main light Dimmer 2 to send commands to Association Groups #4 & #5 which allowed me to turn the lamp Dimmer 2’s on from the extra switch on the main light Dimmer 2. Now that function is not working and the lamp Dimmer 2’s themselves only work properly when I use ‘Fibaro Dimmer 2 ZW5’ as the type rather than the old DH from codersaur. ZW5 does not handle Association Groups, so i’m not sure what to do next!

Any idea how I can get the Association Group settings working again?

Thanks very much

Changing to the new app and switching DTHs shouldn’t effect association. However, if you need to query/adjust association then Tweaker has been updated to work with the new app: [BETA] Z-Wave Tweaker (See post #209 for new V3 app version) - #209 by mwav3

Tagging @davidjc since he has some recent experience troubleshooting Fibaro Dimmer 2s.

1 Like

Check to see what security level the devices are at. One big difference between now and a year or so ago is that now devices which support S2 security may join with S2 security enabled, and at that point they can only be associated to other devices with S2 security enabled.

Here’s the thread with the recent discussion that @philh30 mentioned. The topic title is a clickable link. It’s a long conversation, because he ended up trying a lot of different things before finding something that worked. But it’s possible that your issue might be one of those earlier things so I would start from the beginning of those posts.

1 Like

My main problem was that I had parameter 29 set to 1, which effectively switches S1 and S2. Which means the switch connected by wires to S1 was triggering S2 and not S1. This then forced me to set parameter 26 to 1 ie ‘3-way switch’ enabled, just to get the physical light switch turning the connected light on and off.

@philh30 then showed me how to use the tweaker2 and the logs on the Smarthings IDE to read and change these parameter values. I changed both 29 and 26 to 0.

I also had to make sure that parameter 27 was set to 15 as the associations only worked if sent as secure.

Your current parameter settings may be different to mine, so I recommend you use the tweaker2 to interrogate the parameter settings. You turn on the live logs in the ide and then use the tweaker to publish the current parameter settings. Then see if you have the same issue as me, or at least look through what you have and see if anything is obviously wrong. Use the tweaker2 to change.

I then set association normally, using Association Group 2 (as I am using S1 to trigger my associations), but it sounds like you use S3 and S4. Which should be fine to use S2 to trigger your associations.

The last part to really get the Fibaros working well with the Hub is to set Association Group 1 to ‘1’ which @JDRoberts and @philh30 indicated ensures the Fibaro communicates latest status to the SmartThings Hub.

But also read the mail trail @JDRoberts refers to. Hopefully you know how to add the Tweaker2 to your Device Handlers but, if not, let us know and we can help. I found the code and copied it manually and pasted it as a new Device Handler, but there are probably easier ways.

David.

2 Likes