For all you IFTTT guru’s: integrate Arlo and SmartThings lights

K what I’m trying to do is make it were one Arlo camera come on at a schedule at night. My wife is afraid that my new truck will get broke into or the latest thing going around catalytic converter getting stolen at night so I’ve setup the Arlo camera to detect motion and turn on a LED light thru Smartthings shooting down the driveway while the camera is recording. Here’s the problem 1. How do I make a schedule for the light to NOT come on during the day now I have my Arlo’s setup on a Geofencing so they come on while we leave and off while at home except for the one camera will come on thru scheduling 2. Make the LED light go off after here say motion is gone. Made a IFTTT for this Arlo see’s motion turns LED light on thru Smartthings this works because I came home and the LED light was still on from a motion sensed at 9:07AM this morning it never shut off. So can I make another IFTTT applet to turn off the LED light thru Smartthings once here say motion is gone?

This should takes care of automation with the lights



Lights come after sunset with motion 100% and when there is no motion goes down to 40%

Wyze cams are brought in through IFTTT as motion sensors. When cameras sense motion they flip virtual switch On. Virtual switch goes of after my cooldown period of 15 seconds. If there is still motion camera flips virtual swith on again.

1 Like

I was showing only one Light on screenshots, however I have more than one, but settings are the same

1 Like

K. Here the problem I don’t have Arlo integrate into Smartthings because Smartthings lacks controls over Arlo. So that’s why I’m using IFTTT as a way to control automation to and from Arlo. Unless someone else has figured out a way to turn on and off the Arlo motion detection and turn on and off the cameras then Smartthings it really lacking control over Arlo.

We are on the same boat. Wyze cams are not integrated either. I am using virtual motion switch from @TAustin and IFTTT to activate motion in SmartThings.
You will need to create one virtual switch per camera and turn On the switch in IFTTT when Arlo detects the motion

If you have a camera that supports ONVIF, then you could use my ONVIF driver to get motion events directly from the camera, as well as video streaming. I believe Arlo has at least one ONVIF-compatible camera.

K. Sat down today and started this. Is the Arlo camera suppose to be inter grade into smartthings or not because I’m trying to keep Arlo separated from smartthings So I follow the direction installed driver went to add device scan and nothing is found. Am I doing something wrong or any idea what do next. I appreciate all the help.

Not all Arlo cameras intergrate…you have to check ST to see if your models do. I dont think any Arlo cams have ONVIF support (could be wrong here).

If you dont want Arlo intergrated into ST, Then there is a work around if you use Bixby on an Android device. To create a link to ST.

K. Ran test on the outside light if Arlo detect motion the LED light will come that shines down the side driveway I’ve setup a automation or routine in Smartthings and it works if light is on for 5 minutes then it turns off that all I want it to do just a scare tactic. Tomorrow I’m going to test the Arlo setup I’ve setup a mode called outside lights. Geofencing is still active so while I’m away all cameras are in away mode so all cameras look for motion including the one I have setup for driveway so during the day the LED light will come on and go off if I could figure out a IFTTT to pass a schedule that would be great but on with testing once I get home Arlo mode changes to Schedule Mode and that when the driveway camera will be active at a certain time. So if Arlo Mode test works then I’ll reactivate the IFTTT Arlo to Smartthings and I’ll be somewhat happy. Other than the LED light come on during the day.

Add precondition like on screenshots above.

Okay Arlo test worked so camera down driveway is set to record any motion at a certain time. once we leave house they all turn on into Away Mode. I’ll try a precondition routine BUT I don’t think it will work because the IFTTT applets does a handoff directly to Smartthings to turn LED light on. I’ll try it but I think it will skip over the precondition on to the light.