Firmware Not Updating for Sensors


(Garrett Hensley) #1

For some reason my SmartThings multipurpose sensors will update firmware. I have the setting in utilities to allow OTA updates, but that was over a week ago. I even brought one upstairs near the hub and reset it (pulled the battery) and still no updates. I modified the DTH, could this affect firmware updates? I have one other SmartThings brand sensor (motion sensor) but that darn thing won’t stay online now. I’m really disappointed in the ST brand sensors…but that’s another topic I suppose.

Garrett


(Jimmy) #2

Have you tried forcing it from the device page in the ide?


(Garrett Hensley) #3

You may have to school me a bit here. I checked for the update and it shows there is a newer version available than what it is current, how do I force it to push it to the device?


(Jimmy) #4

Clicking Check now should check and perform it


(Garrett Hensley) #5

Ok, thanks. I assumed the check now only looked for the latest version. I have done that. In fact, looking now, one of them finally updated. It was the one I took down and brought up near the hub. I’ll try that on the other one tonight. I swear I looked first thing this morning though and it had not updated.