SmartThings Community

Fire Tablet Setup Script for ActionTiles [BETA UPDATE 12-4-18]

dashboardhardware
actiontiles
fireos

(Kevin) #314

i just picked up a Fire 8 and downloaded/run the zip. I don’t see the enable adb in developer options. I enable debugging and set the usb to ‘transfer files’. I get lots of DELETE_FAILED_INTERNAL_ERROR
Google Apps, Chrome, Nova etc all install with success.

In accessibility settings the detect home button press will not enable and there is no toggle switch icon.

Anyone else see these issues?


(Aaron) #315

Try to root the device with the link listed a few posts above. It works with root.


(Brad Leonard) #316

In light of the Best Buy Black Friday Sale of the Fire HD 8 and Fire HD 10, is anyone going to provide an updated how-to for the script (if it still works) so that we don’t have to try to make sense of all 301 posts in this thread since December 2017?

My Fire HD 8 shipped with Fire OS 6.3.0.0. It is pending an update to Fire OS 6.3.0.1. I have kept it from updating just in case that somehow messes up scripting capabilities.

looking forward to getting this working. Thanks for any help that anyone can offer.


(Aaron) #317

Quick Synopsis,
Root the Fire using the XDA guide or possibly Kingroot,
Then run this script,
Then update the google play apps.

Should be golden after that, from what the last few posts have said.


(Brad Leonard) #318

This can’t be the only root method for the Fire HD 8: https://forum.xda-developers.com/hd8-hd10/orig-development/root-hardmod-root-amazon-fire-hd-8-7th-t3851617

My time is worth more than this futile exercise.


(Aaron) #319

I think King root works on some versions now. I’ve not kept up with the rooting methods, but I’m sure someone here has.


(Brad Leonard) #320

I have Action Tiles Running in the Silk Browser, and I installed the “Screen On” App from the Amazon App store. it has been running without issue for the last two hours. I am going to see what happens over night.

What could I expect to gain from rooting, removing Amazon bloat and installing Chrome and the Google Play Store? The only thing I can’t get to operate right now, are HTTP images captured from my cameras but those aren’t even loading on my Samsung GS9+.

Are people running the SmartThings app on these tablets when they are rooted so that they have notifications?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #321

Unfortunately, the SmartThings App (neither version) will work; You can install it (either from the Play Store or by finding an APK), but the login process requires Chrome or Samsung browser, and since Silk is the default that cannot be changed, the login process fails.

I’ve heard that with the right ADB hacks this might be overcome, but I’ve not heard of many folks reporting success.

Samsung / SmartThings is well aware of this issue.


(Steven ) #322

Quick question. I noticed that the script doesn’t seem to be loading the special FIRE OS APK for Fully. Should it,or does the rest of the rooting and other steps basically get you to the same place?


(Aaron) #323

You are absolutely correct. I am actually in the process of updating the script today.

If anyone has suggestions, let me know and I will try to add in!


(Steven ) #324

I got my Fire 10 working well with the stock version, but just noticed on the ActionTiles site a thread with the Fully developer who pointed to the specific FIRE version. I’ll wait to get your updates!


#325

Anybody is having issues with Fully shutting down after a few mins? I’m using Fire 10


(Kevin) #326

I got an HD8 couple weeks ago and posted here about errors in the script output (scroll up 6 days). I read the root procedure and decided didn’t want to take brand new HD8 apart and modify hardware…

So I just let the script run and continued through the errors. I ended up with Google Play store and Fully installed but not Nova Launcher (or it wouldn’t run I forget). I started Fully and went to actiontiles.com and it seems to be working, keeping screen on. I slapped some CommandStrip velcro on it, pulled the slow Fire7 off the wall and HD8 is working great. I’m not running LAN Announcer, SMartThings app or anything on it.


(Ron Talley) #327

I have a bunch of FireTablets all over the place and occasionally I have to restart them. Don’t know exactly what makes them act up but they do. A restart typically makes them work properly again.

Fire 10s, 8s and 7s.


#328

I think I’m experiencing the same issues. Thanks I will restart them and see how it goes


(Brad Leonard) #329

I am testing this on my Fire HD 8. I had side loaded Google Play, and installed Full Kiosk Browser and Screen On. It had been working just fine in testing, but when I got home last night the screen was on but with but the advertising lock screen. Long story short, it had completely factory reset on its own!
It asked me to log back into my Amazon account and accept all of the Ts & Cs again. So weird.


(Rich) #330

I am unclear why this is even needed. I haven’t rooted any of my fire tabs and they all work great with AT, Fully and chrome browser. Fire 10’s, 8’s and 7’s. New and old gens.


(Ron Talley) #331

This use to take the ads away, block updates, ability to remove bloatware and a couple of neat apps to make the FireTablet and ActionTiles experience more fluid.

Personally, I asked Amazon to remove the ads on 3 of mines and they did after this script no longer worked to remove the ads. I also paid Amazon on about 3 more to remove the ads after they refuse to remove them for free on the newer ones.

I also paid for the Pro license of Fully for all of my Tablets. I believe it was a 10 device volume license.

Finally, I have about 5 Fire Tablets that stay on with Alexa hands free available. These also run DAKboard which is cool and can do a Photo Slide Show as the Screen Saver. All the other ones shut off after a given amount of time. I DO NOT want Amazon feeding me their ads when I hit the home button to get to the lock screen! This script, in the beginning, took care of that problem.

YMMV


(Rich) #332

Ok, so to save dolla dolla bills yall… gotcha.

Thank you Ron


(J) #333

Thanks for this script! Worked great with an old Fire 7 I found. Don’t know how to use lannouncer yet, but researching.