Best Tablet for an inexpensive wallmount Controller?

I was thinking of getting a tablet to mount on the wall for control of smartthings. I was wondering which was the best for the least money and most usable. I hear you have to take all the crap off the Fire Tablets to use them properly. Any comments appreciated.

2 Likes

I think I saw mention of that in the Action Tiles thread. I have a Fire 8 HD. Not using it for ST, but it’s a really decent tablet for the low cost. You can strip all the lock screen ads and unwanted apps if you want. Some will come back with an update, so I just file them out of the way instead of removing them.

Recommendation: Buy an android table unless you have an old, unused Fire Tablet.

Amazon makes a good tablet. Very good for ActionTiles. Buy without ads (cost $10 more).

If you are planning on running the SmartThings android app, beware.

  1. In the past, some users could not access their SmartThings account. Affected new users after about May of last year.
  2. You must load Google Play using some special instructions. One example: https://www.laptopmag.com/articles/get-google-play-on-fire-tablet.

For ActionTiles; Google Play is not required.

  • ActionTiles will run in the native Silk browser.
  • The popular Fully “kiosk” browser can be installed via APK directly available at http://fully-kiosk.com

Thanks for all the recommendations, everyone! Just a tiny note: The app name is “ActionTiles”, one word, and our Trademark.

Terry,
Thanks for the correction. I do not use ActionTiles. Been too busy learning to program in the SmartThings environment. But it is on my to-do list. I know you are a major supporter here and appreciate your continual work.

Dave

1 Like

If you don’t want to deal with the Fire manipulations, there are a slew of android tablets out there with 16gb storage for $35-$40. Walmart and bestbuy both carry them. They are perfectly suitable for this task. I have two in my home, one at each entrance.

1 Like

I have Walmart RCA tablet and it has problem staying connected to wifi. It works well if connected but it loses connection each day. To fix, I toggle wifi and reconnect and it works. Verified it’s not action tiles because it happens with other webpages as well. Not sure how to fix but this renders the RCA useless in my home.
By they way…if anybody has fix I would appreciate it. I’ve tried all things found on other forums with nothing being successful.

1 Like

If you have access to Tasker, maybe you can set it up to toggle wifi on a schedule so many times a day.

1 Like

Good thought. A ‘work around’ might be my best option.

I prefer the Amazon Fire Tablets because they also come with Alexa hands free.

2 Likes

Old thread, but what about the non-brand name Dragon or Vankyo Android 9 and Android 10 tablets available on Amazon from $85-$135 which have at least 2gb of RAM that the SmartThings app apparently requires. Has anyone used any of them for a wallmount SmartThings?

I haven’t tried those. The fire tablets run actiontiles really well. Get them when they are on sale and they are cheap, have good resolution and plenty of power. Alexa is a plus if you use it. They do not run the New ST app because they never fixed the browser issue which allows you to sign on.

As for Amazon Alexa, the Alexa app can be set as the default Assist application on Android. However, I’m not sure if the Alexa app as the default a assistance on Android is the same experience as it is on the Fire tablets.

Also, these Android tablets should be able to run the new SmartThings app since they have 2gb of memory and native access to the Google Play Store. And they would also have access to any flavor of Android web browsers.

I’m just looking for a cheap native Android solution that doesn’t need any tweaks to setup. Not to mention that they don’t come with the Amazon adds feature that cost more to get turned off.

However, Amazon just added the the Smart Home Device Dashboard which looks interesting. I wonder if they’ll bring the Device Dashboard to the Alexa app in place of the current Devices tab. If it’s a separate app, then since the Fire tablets are Android based, I wonder if the apk can extracted and sideloaded on other Android devices. And, I hope they’ll bring the new Device Dashboard experience to Fire TV devices as well to replace Smart Home Dashboard on it now.

Fire tablets default to the silk browser when you try and sign into ST on the new app. Even though you load Google services and the play store to the tablet. Samsung does not run on that browser and so you cannot login. At least that has been my experience.

Not sure if Silk is a problem. I just happened to install Fire Fox right after side loading Google Services and Play Store. The ST app was no problem.

So when you login to smarthings and it goes to a browser to ask for you id, you get that on Firefox? I have firefox installed and have it as the default. Still goes to Silk on that item.

I do not recall seeing such a message. Let me make sure that I understand. Both Firefox and Smartthings were installed from the Google Play store? Not sure if there are Amazon store versions of either, so sorry if that is a silly question.

When I get home, I can look to see if I changed any other settings that could have an impact.

Yes. Both from the play store. I have the same issue on multiple tablets. It started when they changed from using smarthings id to samsung id which was quite some time ago.

Thanks

Turns out that I disabled Silk in the app settings. Hopefully that helps.