Fibaro Relay FGS-212 - Can't connect

I’ve just bought a Relay Switch to wire up to my pond pump, however I’m a little confused about the wiring diagram and how exactly to configure this with my setup.

Currently, my pump goes to a fused spur (essentially a hardwired plug socket). The requirement for the pump is that it must sit behind a 3A fuse which is in my fused spur.

What I want to do though is have my relay so that I can control the pond pump from SmartThings, however I also need to be able to control it manually. Now, I know that I could put a switch in to control it but I don’t really want to due to its location and I can’t find a suitable outdoor momentary switch, however this leaves 2 questions:

  1. Does the relay go back to its ‘on’ state if the power is cut and restored, like Hue bulbs do?
  2. How would I wire my pump in without a switch?

How else will you be able to control this “manually” without a physical switch?

I believe the fibaro relays can be configured to either return to their previous state in the event of a power cut, or return to the off state.

I’d stick a suitable outdoor switch round the back of the pond. Something like this:

There is a fused spur which would act in exactly the same way as turning a plug socket on/off. If its off via ST, then turning the spur on/off would turn it back on.

Ah, I didn’t realise that the fused spur was switchable. I imagined a fixed fused spur.

If you switch off the spur it will mimick switching off the mains, not a switch connected to it.

In order to have it manually switchable then you would need to add a switch across the relevant terminals on the relay.

Without that, you could manually switch it off at the spur, but you would have to use your smartthings app to switch it back on again.

Unless you set the device to remember it’s state when mains is cut.

That would allow you to switch on and off manually, but if you switch it off with the app, you would not be able to switch it back on again solely from the spirit switch.

Hope that helps.

1 Like

Yep that makes sense as to what I thought, so I get this scenario:

  • Spur On. Controllable via ST
  • Spur Off. Can only be turned on via the spur which will turn the pump on straight away

Essentially, I can use it remotely and if I go away on holiday, I can just turn it off at the spur in case of a power cut until SmartThings is able to return devices back to their original state in that situation.


The only addition however is that if you turn the pump off using the app, you will only ever be able to turn it back on by using the app.

Would turning it off and back on at the spur not restore the power back to the Relay, and in turn, activate the pump? (Like what happens with Hue bulbs etc when the power is cut - they turn back on when the power is restored)

No. The relay would either come back to the off state (default parameters) or if the parameter is set to remember it’s last state, it would also come back to the off state as that’s the state it was in after turning off with the app but before switching off with the spur.

If it was me, I’d find a convenient place to connect a switch to the relay terminals so you can use it fully.

Ah OK. Well the relay will be here tomorrow and I need to get a gland for the cable anyway, so will pick up a switch.

Doesn’t it need to be a momentary one though?

You can use either momentary or toggle - on the FGS-212 relay, you just need to set parameter 14 to the appropriate value. 0 is for momentary, 1 is for Toggle. By default it is set for toggle, so a small weatherproof toggle switch will work just fine. :slight_smile:

OK so just wiring it up now. Can’t say they’re the easiest things to follow, however I think I have this right

My pump live will go into Q and its neutral will feed back into N.

Is that correct?

That looks correct to me. Pump neutral to N and Live to Q as you state. (and connect the pump earth if it has one).

Just make sure there aren’t any loose strands sticking out of the terminals, otherwise there may be a short when you shove the lot back in the switch housing.

Hmmm. I can’t get this damn thing working at all.

I noticed that the com port on the switch is supposed to be the live and L1 is the load for momentary switches so changed that around, but it still wont appear in SmartThings.

Any ideas?

Is the fused spur on? (daft question but worth asking).

Have you tried rocking the switch three times very quickly to get the device into inclusion mode to be picked up?

Other than that press the button three times quickly on the back (I try not to do this method as it involves poking around in the switch box while stuff is live - if Im going to do that I put the devices on my test bed where everything can be spread out and safe)

Yep, I’ve tested the connections too.

Currently live are:

  • Live
  • In
  • S1

Is that a momentary or a toggle switch?

Momentary. Its the BG 20X one:

Says in the instructions:

Connect the Live wire to the comms
connect switch wire to L1

My Spur goes to my comms and then S1 goes to L1


I added it manually via the IDE as the following:

This actually works, but the momentary switch doesn’t work :confounded:

The FGS 212 I do not believe is Zwave plus, just Zwave - so it will need to be included while in range of the controller.

If you have a momentary switch (rather than the toggle I pointed you at :wink: ) Then you will need to update the parameters of the device to set parameter 14 to value 0. By default it is set to 1 which is for a toggle switch.

So you are going to need a custom device handler made from the template for a Fibaro Relay.

First things first however, lets get the device seen in smartthings.

What I would do is just get simple cable with a plug on the end. wire the Neutral and Live to N and L of the relay module.

Plug it in near the hub, and see if it can be added now. (you’ll have to push the button on the back of the module as you wont have a switch connected)

Now, having said what I did about the default being to operate with toggle switches - the manual conflicts itself.

there is a cuation section which states:

"CAUTION Fibaro Switch is set by default to operate with momentary switches (i.e. single-pole switch or bell switch). While adding Fibaro Switch to the network with toggle switches, ensure that all switch contacts are open (off), because closing them results in activating the push-button and this will prevent adding the device to the network.:

There is then the section about parameters which states:

Parameter No. 14 - Switch type connector, you may choose between momentary and toggle switches. Default value: 1 Options for changing the parameter:0 - momentary switch1 - toggle switch

So God knows what the default is.

Yep this is exactly what I read.

I’ve actually got it in SmartThings now as I added it manually as a Z-Wave Multi-channel Device, as thats what it was picked up with originally.

I’m wondering whether somehow I’ve triggered it to be a toggle switch, but then again, the manual doesn’t make sense…