Fibaro motion sensor wrong temperature


(Turuncuoglu) #1

My fibaro show the temperature as 173. I am pretty sure it is not that hot in the house. I have tried various device handlers and I got the same results.

I have contacted Fibaro tech support and they told me it is an issue with ST. Anyone has the same issue or a fix for it.

Thanks
T


(Paul) #2

What device are we talking about?


(Turuncuoglu) #3

Motion sensor.


#4

@slagle, looks like the function “convertTemperatureIfNeeded” in the Fibaro motion sensor zw5 is broken.

Pls help to check. Another reported issue some time back:

[Released] Fibaro Motion Sensor v3.2


(Turuncuoglu) #5

it is zw5 motion and temp sensor. Thanks for your help.


(Bob) #6

How about trying @CSC s device handler.
Works brilliantly and you can change the parameters to suit your needs.

[Released] Fibaro Motion Sensor v3.2


(Turuncuoglu) #7

I have actually tried that handler along with two others but the result is same. I realized yesterday also that the motion is stuck on motion all the time. I have deregister the device from the hub the result is same.


(Bob) #8

Hmm mm. Sounds like it may be faulty.


(Turuncuoglu) #9

That is what I was thinking but fibaro thinks it is not. they think it is an issue with smartthings. Which does not make sense to me.


(Bob) #10

How about starting again from scratch.
Dis-associate the sensor. Then reset the sensor to factory settings. It tells you how to do it in the manual.
Then start again.
As soon as it is discovered go into the ide and change the DTH to @CSC’s.
You may have already tried all of this but if not I would give it a go.
Good luck.


(Turuncuoglu) #11

Trying it now.
Thanks


(Turuncuoglu) #12

Thanks Chan,

This solved the issue. So do you think this is an ST issue or aFibaro issue?