Fibaro Dimmer S2 not playing nice with Webcore

Hello. I’ve gone through the forums and gleaned as much info as I could about the Fibaro Dimmer 2 and using the s2 function for that type of Scene Control. I’ve changed the DTH to the codersaur one and I’m using the Webcore Piston that’s floating around here.

Nothing seems to be working. When I press S2 and look at the logs for the device, nothing seems to register (not sure it should).

My question is two-part. First, are they any DTH parameters that need to be changed/set. Second, could someone please look at the piston below and make sure it’s correct? Thanks much.

Have you got parameter 28 enabled?

Yep parameter 28 will cause that. Also consider switching to the stock DTH. The Codersaur one has some nice extra features, but the stock one runs locally. Both do scenes.