Fibaro dimmer 2 not working (no response) (August 2019)

The dimmers are visible in the app as “off”, but not possible to use. When trying to dim or turn the light on, I get the pop-up “Server or network failure”.

Happened while pairing devices. Anyone with similar experiences?

Seems related to a firmware upgrade but have not received a confirmation from ST staff.

Anyone with a solution?

Even unpaired the dimmers and factory resettled the ST hub and paired all devices in again, but got same results

Unfortunately, many people have reported this as a problem after the last hub firmware update. :disappointed_relieved:

Make sure you report it to support, as the more people who report the problem the more resources they will assign to it.

Yes me too, they’ve just acknowledged it and are working on a fix. But send a support ticket in so they don’t forget! :wink:

1 Like

And they’ve just fixed it! A VERY helpful ST engineer just asked me to check! Wow!


Thanks for the info. Seems like a problem others too have experienced, and hopefully fixed very soon

Ok, thats promising!

Is it really fixed? I am still experiencing the same problem.

Yes, my issue has been fixed and permanent fix will come in the next firmware update. Maybe you have a different issue, I’m not sure.

I think only Alwas system is fixed

I tried to unpair and pair a device. One out of 1o efforts was succesful, so there is some hope:)

I tried to use various generic DTHs in hope of a better outcome but the problem stays. Anyone with a suggested solution for the Fibaro dimmers?

And it’s broken for me again. Have to wait until the next firmware upgrade to gain control of my lights I guess. Support said “in the coming week or so”.

I have the same issue. When will this FW be ready?

Same Issue here… 2 out of 10 dimmers are working. Can see how much power is drawn from the ST app when using the switches, but cant dim or turn on/off from the app. My two Fibaro double switches are working fine and all my ST and IKEA devices are working…

Sounds just like here. Can se the state and power consumption. But controlling it is not possible.

Is this resolved?
I’m not sure whether I’m affected by this

I’ve just tried pairing a fibaro dimmer 2, its been difficult to get it to pair, and now it wont turn on. I have existing fibaros purchased at the same time (bit paired about 12 months ago) still working fine. I’ve tried 2 now and get the same problem

Hi Paul, that is exactly the error. Not fixed yet it seems like.


I think I’ve made things work trying to resolve. I’ve run some of the z-wave utilities (disable/enable network & repair network)
I did find an orphaned device which I managed to remove & also removed & reset the fibaro dimmer. I’ve managed to get it to connect & it works(it still shows the zwave-s0-failed message.

The bigger problem I know have, is my other fibaro dimmers & fibaro double switch have stopped responding. A fibaro single relay still works.

I removed the double switch (from st IDE) powered it off, re-booted hub & repaired network before pairing again, however, it still does not respond.

Other non fibaro z-wave devices still seem to be ok.
I’m not sure what to do now, I’m wondering about removing all fibaros & re-pairing, but its a large task and I’m not even sure that would fix it.

Hey All,

We released 0.27.8 yesterday that should fix these issues, if you are still having issues with Fibaro Dimmer 2s, please try exclude and include the device, if you are still having issues, please let me know.

1 Like

Thanks, things seem to be working again.

Some of my fibaros came back after the hub upgrade. The remaining ones I’ve removed and re-paired and they’re working again.

A tip for anyone else with these problems, I found I needed to remove the device from the ST IDE rather than the ST app.

still have a problem with my fibaros. did delete and readd no luck


Made it work. had to delete it in IDE and factory reset the singel switch. i now have ZWAVE_S0_LEGACY and response in app


I now added a fibaro dimmer with dimabel leds lights. get green light in fibaro after calibration but app will not dim the lights. give me network error