FAQ: Zwave repair not working (how to fix error messages)

Thanks for these instructions! I’ve got 2 ghosts I’m trying to get rid of. I’ve followed your instructions but having an issue with step 5. After attempting to force-remove the ‘Trash’ devices, they don’t actually get removed. I can delete them from the IDE, but they still appear to leave their ghosts behind that are fouling up my zwave network repair.

Any thoughts?

At this point, I usually wrote to support. Then they are gone in a couple of days.

1 Like

From my experience deleting from the app rather than IDE seems to work better. Sometimes the app doesn’t refresh without getting a serious kick in the …

1 Like

FWIW, info from a newb (me) here:

I was having a hard time with a Lowes IRIS garage door controller GD00Z-1, and it was reporting an UNKNOWN status. After spending some time on the forum here, opening an closing the door via the wall switch, checking sensor batteries, etc, I went to the repair Z-Wave Network section of the mobile app. For the garage controller, I got both:

“Network repair for [device name or ID]: Failed to update mesh info”
“Network repair for [device name or ID]: Could not assign new route”

I got the same result from the IDE.

I had added/paired the device from just a few feet away from the hub as suggested here. I ended up removing and excluding the opener, and re-added it. This was with the hub maybe 20 feet from the controller. Everything worked perfectly. I even tried a repair, and it reported no errors. FYI, I had to download the instructions for the GoControl branded GD00Z for exclude instructions, as the IRIS controller instructions were specific to the IRIS hub.

It’s unfortunate that this install took about 2 hours instead of the 20 minutes it should have. Hopefully the second garage controller goes a bit more smoothly.

1 Like

I’m trying to do a Force Remove. I went to edit the device, clicked Remove. Waited for that to timeout, then clicked the Force Remove button and OK. SmartThings says it was successfully removed, but it is still showing up in both the App and IDE.

So I too had two phantom devices. So after reading what was described above I tried it and as you said it no longer works. So I tried a new variation and it worked on both of my phantoms. I had an extra receptacle that I made sure was not in my network by trying to removing it using the app removal process as described above. I than created a new device (called trash) with the type I know that is would used by normal pairing process (for my receptacle) plus of course the phantom network ID. (Now the change. Using the app on my phone I did a “replace” on the trash device. When it asked me for the new device I triggered pairing on my unused receptacle and it replace the phantom to the newly pared working receptacle device. Than using my phone app, I removed the trash device (which was a working receptacle). I re-ran Network repair and the phantom is gone. Doing it for the second phantom was the same process. Both phantoms are now gone and I have a clean Repair.

4 Likes

I keep getting the Failed to update mesh info for two of my devices they were working and nothing was moved there’s one zwave switch that i installed that should be making connection better since it’s a repeater. I’ve read all the information but I’m confused because that in on post, I read hub should be powered down for 15 minutes then brought back up then repair initiated . in another I read that only works for zigbee. The hub is about 9 feet from a Leviton DZS15 switch and then my problem switch is an Enerwave ZWN-RSM2 PLUS hooked to a ceiling fan is in the next room about 15 from that switch. What’s the best way to get these working right? (it’s my bedroom and my GF is getting pissed that lights aren’t working.

Most mains powered Z wave devices are repeaters, including the two that you just mentioned. It’s battery powered devices that don’t repeat.

Did you see the following above?

Note in particular that “failed to update mesh information” won’t cause a problem for the network if that particular device was a battery powered device because they don’t act as repeaters. But if that device is a repeater, it can’t be used in routing until the error message goes away, so you can lose access to a lot of other devices down the line.

If you were getting the “failed to update” from a wired device, something is seriously wrong. Check the wiring to make sure the connections are good. For a switch, test the switch manually to see if it’s still controls the light and if it’s LED comes on appropriately.

I would also contact support in case they can see something from their side.

https://support.smartthings.com/hc/en-us

This worked, thanks. But what a pain!

1 Like

This is a great asset for a frustrating problem :slight_smile: any thoughts on how these ghost devices appear to begin with?

Typically, it’s a cloud artifact. Somehow you succeed in deleting the device from your cloud account without ever actually deleting it from the device table that the Z wave controller inside your hub keeps for itself.

There are multiple ways this can happen in a SmartThings environment. Manually editing the device list through the IDE can do it. Doing a remove which for whatever reason fails to complete fully can do it. Database corruption in the cloud account itself can do it. There are couple of other possibilities as well.

Thanks - I’d guess it was one of the few times I moved a device and renamed it or something along those lines. I’d guess this might be a common pitfall for those unfamiliar with the way things work.

I was hoping this might solve my phantom device problem in Google home, but no dice. A similar strategy (renaming a device and then trying to delete it) just gave me two devices with the same name :slight_smile:

1 Like

Did you ever find a solution? I’m having a nightmare of a time with my setup and I experience the same symptoms when running a Z-Wave repair. After pressing “Run Z-Wave repair”, all I get in the Android device, is the spinning circle. In case of the iOS device, I get one step further with a “Repair Started” message. Running it in the IDE on my laptop, show no messages in the IDE log.
So I was wondering how you got the repair to run.
Thanks

I’ve never had luck seeing events during a repair in the app. From the ide, you’ll have to go back to hub - “list events.” It doesn’t default to the events page when you start a repair.

2 Likes

Thank you, this opened a completely new world - never thought of looking there.

1 Like

It’s a circuitous route, I agree. Welcome to SmartThings, it’s not perfect, but it’s flexible.

Can one tell from this log if the repair completed?
I found this entry: zwNwkRepair started Z-Wave network repair started
But nothing about having completed successfully / failed. It’s been running for more than an hour now. (I have 177 entries in my device list (which obviously include a few virtual switches; 40 Hue lights; about 20 alarm sensors (linked through Alarmserver).

Has it finished yet? I’ve got about 60 devices, and it can take 20min or so to run all the way through. You will get a “zwave network repair completed” statement at the end.

1 Like

Zwave repair should only involve your physical zwave devices. No Hues, no virtual devices, no zigbee devices. It can definitely take a while though.

Nope, after more than an hour, it was still going at it. I either have a bad hub, or a device is messing with my network.