Evolve LTM-5 transmitter to LRM-AS association


(Shanv) #1

I replaced a three way switch setup with the Evolve LRM-AS and Evolve LTM-5 devices. I was able to associate both with the ST hub and I can control the light switch part of it just fine from the ST app. The LTM-5 is essentially a secondary controller which doesn’t use the traveler wires like the old setup did. The LTM-5 is recognized as a switch when I run through the mobile app’s add device option. When I press up and down on the paddle, ST does see the events.

The problem is that I cannot find a way to associate the LTM-5 with the main dimmer switch. It appears as if I need to use a more traditional controller like a Vera or one from Evolve to do this.

I do see an option for “groups” in the developer web UI but I don’t see any way to create groups.

Any help would be appreciated.


Wiring three and four way switches - any diagrams out there?
(Shanv) #2

It appears as if the ST hub and software just doesn’t support the concept of “associate.” Research has shown that this IS supported by the Vera and even the little Aeon Minimote.

This unanswered thread also seems to indicate no support for this in ST - http://build.smartthings.com/forums/reply/reply-to-schlage-nexia-lock-remote-administration-11/


Linear 3 Way Led Dimmer
(Mr Matt57) #3

This is something I would like to do also. Most system seem to support z-wave association, am I missing something? Can this be done with a SmartApp reliably even with switches that don’t support instant local notifications?


(Mr Matt57) #4

Wanted to follow up on this. I was able to get zwave device to device association working with the Evolve LRM-AS and LTM-5. I ended up using the Aeon Labs minimote (as @shanv mentioned above) as a secondary controller to SmartThings. Here are the steps I took:

  1. Paired both switches to Smart Things (put SmartThings in “Add” mode, then double tap switches)
  2. Paired Minimote to SmartThings (put SmartThings in “Add” mode, clicked “Learn” button on minimote)
  3. Clicked “Associate” button on Minimote
  4. Double clicked LRM-AS (Main switch)
  5. Double clicked LTM-5 (Aux switch)

I was note able to find a way to do this directly within SmartThings. The groups referenced within the IDE seem to only refer to the Things grouping within the mobile apps. For what it is worth, I also have a GE 45601 remote and it’s grouping and scene definitions also do not set ZWave association. It would be nice to have the zwave utilities section built out to include this functionality.

So far the switch is working flawlessly, it works exactly as the main switch with dimmer controls and all. I am very pleased, as this is the best dimmer I have found for low draw LEDs lamps and I have several 3 and 4 way switches that need to be added.


Linear WD500Z + WT00Z + Aeon minimote issues
FS20Z-1 for Gas Fireplace? How to wire? I have fan switch nearby
(Huntb) #5

I think the nice thing about ST is that you don’t really need to associate the two switches. You can use an app, such as The Big Switch, to accomplish this. At least that’s what I’m hoping because I just ordered a linear dimmer switch as well as a wireless associated switch.

Now that I think more about this… maybe dimming won’t work without modifying the app? I’ll have to look into this more.


(Huntb) #6

I believe that I found a solution for dimmer switches. There is an app called “Multi Dimmer” under My Apps by Brad Sileo that should work. All I had to do was uncomment Line 39 to get full functionality. I have this working through my ST app but am not home to check to see if it works with the physical switches. Also, I have only verified this on two hard-wired dimmer switches, I do not know for certain how this would work with a master/aux switch setup. What you would need to do is install this app twice, once for the master switch and once for the aux switch.

The only problem that I see with this is that the command has to go to the ST cloud and using the aux switch may cause unwanted delays. I’ll update this once I get my Linear master/aux dimmers installed. FYI the model numbers are - Master: Linear WD500Z-1 and Aux: Linear WT00Z-1


(Mr Matt57) #7

The problem with using an app is that most of the less expensive zwave switches do not 100% support instant status updates. SmartThings has some workarounds in place to “help” with this. @Duncan and @chrisb do a great job at outlining the limitations in this post:

The other nice thing about device to device association is that it will work without a controller. So if my internet/hub is offline, all the physical switches will still work. Until presence detection is vastly improved and the automation is to the level you don’t even have to think about lighting, dependable physical switches for me are a must. It is hard to accept an inconsistent experience for something as basic as a wall switch. The hard-wired Aux switches are also and option, but I haven’t found any dimmers that work well with LEDs.


(Huntb) #8

Welp… can I borrow your minimote?! I’ve got to imagine ST will add something in the future to accommodate wireless associated switches. I can’t justify buying a $50 remote just to accomplish this… It looks like the longest delays I will see are 6 seconds. Which is more than enough time to walk from the aux switch to the master. SMH


(Shanv) #9

My solution to the problem was to buy an Aeon Z-stick Z-wave USB interface on eBay, install homeseer 3 free 30 trial, make it a secondary controller and setup the groups and associations there. This is really a big missing piece of an otherwise excellent SmartThings experience so far.


(Huntb) #10

So I got both of my switches installed today and there is no way an app can reliably control wireless 3 way switches. Looks like a separate controller is on my grocery list now… what a bummer ST doesn’t have this included in their platform


(Huntb) #11

@mrmatt57 can you go into the IDE log and see what happens when you hit the Associate button on the minimote? It would be awesome if we could know what command the it sends out. If we could figure this out, we might be able to create a smart app and use a virtual momentary switch to associate devices without having to buy additional hardware.

The device type code looks like there are several debug statements when commands from the minimote are sent


(Huntb) #12

Bump. Anyone with the Minimote able to test this out?


(Mr Matt57) #13

I will run some tests tonight. I am not sure if anything will show in the logs because as I understand it, the Minimote is functioning as a secondary controller and communicating directly to the devices.


(Mr Matt57) #14

Sorry for the delay, I was waiting to get some new switches in and test with a clean association. Unfortunately, I am not seeing any of the minimote commands in the SmartThings hub log. All I see is the regular switch activity. :frowning:

It is also worth noting that switching the Auxiliary switching from within the SmartThings interface does not control the associated master switch. This isn’t an issues, because everything still works directly on the master.


(Jeff DeWolfe) #15

Anyone have any more updates on this? I tried adding this switch in tonight and cannot get it to control my LRM-AS. Is it possible ST Support would be able to do this?


(Jeff DeWolfe) #16

Just as an FYI, I’m working with SmartThings to come up with a roundabout way to accomplish this until they get it added to the GUI. I’ll post back if we get something working.


(Cpaulik) #17

I was able to get the LTM-5 switch to communicate with the LRM-AS switch via @shanv’s method of using the Aeon Labs’ Z-Stick and Homeseer’s software to associate the two switches. Both switches are now working properly when they’re physically clicked and when clicked in the SmartThings app.

However, I’m having an issue with the status being incorrect in SmartThings when the switches are physically clicked. In SmartThings, the switch will appear off when it’s really on, or vice versa. This issue is probably occurring since the switches were associated by the Z-Stick, but does anyone know of a way get the status to appear properly in SmartThings?


(Jeff DeWolfe) #18

That’s awesome. Glad to hear you got it working. I’m hoping SmartThings will get this going soon so I can get mine to work. I don’t want to purchase a Z-Stick to only use it once…


(Different Computers) #19

Since the last post a month has gone by and I’m reading this thread for the first time because now I have a virtual 3-way switch with an LTM-5 involved.

Any update on making this work?

Looks like I have the added challenge of the LTM 5 switching inconsistently showing up in ST. Sometimes ST sees a switch press, other times it doesn’t.


#20

I purchased several linear WD500Z dimmers (10+) and some WT00Z associated switches (7). Putting in LCD recessed lights and these work nicely with them. However… ST apparently still doesn’t support the association function. sigh.

With regard to using the minimote to perform hype association, Is association permanently tied to remote, or is it just a device to initiate the association?