Error Message when Adding Aeotec DSD37-ZWUS Repeater

I recently purchased this repeater and was able to pair it with my STv2 Hub. However when monitoring the live event logging during the inclusion process i noticed the following error message appear:
12:53:40 PM: warn Exception ‘java.lang.StringIndexOutOfBoundsException: String index out of range: 3’ encountered parsing 'cmd: upda, payload: ted’
I’m wondering if this cryptic error message means the repeater is not going to work correctly.

This is noteworthy to me because I’ve not been able to get my BE469 Schlage Camelot lock, which is too far from my hub, to relay through this device successfully and come under management. I’ve confirmed via reviewing the product conformance statement that the device is capable of handing beaming traffic.

Further frustrating is the fact that there is very little to almost no good documentation for using (& troubleshooting) this repeater in a ST-enabled z-wave set up.

Has anyone seen this error or used this repeater successfully that can offer some insight?

I’ve opened a case with Aeon Labs for this issue. Will post findings.

I opened a case with Aeon Labs for this issue and will report back to this thread.

You can ignore that. It’s a SmartThings bug, but it doesn’t have any effect on anything so hasn’t been a high priority.

I’d recommend emailing for help getting your lock connected.

1 Like

Thanks Duncan, that’s good to know about the error message.

I hadn’t thought about opening a case with SmartThings; wasn’t sure they’d work with me on troubleshooting two products that aren’t part of the “SmartThings” product line to work in my setup.

Here’s what i got back from Aeon Labs Support:

The repeater will work with door locks as reported to me in the
past by a few users, though it may be annoying to set up if it doesn’t
work initially.

Here are some requirements for the repeaters to work for the door lock:
1) The Door lock must have FLiRs enabled (repeater allows beaming which allows the repeater to wake up the doorlock).
2) The door lock and repeater must see each other as neighbors

Some suggestions to force the door lock and repeater to see each other as neighbors.
1) Re-include the door lock after the repeater has been included
into the network to force the doorlock to see the repeater as a
potential neighbor. (This method may require you to move the gateway
closer since the repeater does not support NWI).
2) Wake up the door lock, and run a network heal or optimization to update neighbor nodes

> The repeater utilizes general Z-Wave commands to repeat signals
> hence the mesh network that is used. That is where neighbor nodes play a
> important rule in repeating signals. In this case, the repeater is
> compatible to all Z-Wave networks as long as it is inside the network.
> The main function that allows door locks to work with the repeater is
> the beaming command that i can send to wake up sleeping devices such as
> door locks.

> So if it is connected to your network and if you can communicate with it, then the repeater is not defective.

Last night i followed the steps regarding the network repair/heal in the community post: A Guide to Wireless Range & Repeaters
Turned off the hub for 15 mins, turned back on, ran a network repair, waited
15 mins, ran another network repair, waited another 15 mins and did one last repair.
After all this i still couldn’t manage my deadbolt.
But in the IDE logs i noticed that while the repair was executing, the following message was logged:
"Network repair for “Repeater” [1D]: Failed to update route"
This message appeared during all three repair scenarios.

I feel your pain. A lot of randomness at my house today.

If you have a v2 hub, did you also take out the batteries when you unplugged it?

If so, the best thing is to report it to support, there are things they can look at from their side.

Yes sir, batteries were out, completely shut down for the 15 min span.

It seems the only way i can get this one lock to come under management is to move my hub closer to it and stand it on end so the bottom cover faces towards the center of my house. So it’s now sitting on my hallway floor with the cables running to it from my office 15 feet away! Not exactly ideal when the wife and kids are going back and forth!

I guess i’ll just open a case with support as i’m at my wits end with this.

****Note to Samsung SmartThings Developers----> PLEASE PLEASE, PLEASE give us the ability to actually see the zwave/zigbee routes/routing tables so we can further our troubleshooting efforts!!!

1 Like