Desperate help with danalock & smartthings

Hi all,

im wondering if anyone can help as im at my wits end at the moment,
ive just spent £300 on a ultion Danalock z-wave smart lock, but i just can not seem to get it working on smartthings, its supposed be fully compatible with smartthings but im loosing the will to live by trying to get it working, i want to add it to smartthings so i can use the lock away from home and also on Alexa,

Now i do what is suggested and put the lock into pairing mode and search on smartthings, when it finds it i rename it to Front door lock and add, but once its added the icon goes all greyd out and when i tap the icon it says “Cant connect to device, check device and try again”, ive tried about 100 times now and always the same thing happens, im feeling like ive wasted my money on smartthings and the door lock at present so any advice on this would very much greatly appreciated, im not the sharpest with smart stuff so please be gentle with me, thanks in advance

Hi i have danalock z-wave. As far as i can see they are basically the same lock. Remove it using the exclude function inside the app, and then go to smartthings, brands, danalock z-wave, and add it by pressing the button on the lock and entering the code for S2. Make sure when adding the lock, it must be within 1 meter from the hub. Then try again and let me know.

Hi Andremain,

Thankyou so much for the reply,
I did try this the other night where I took the smartthings hub out to the lock with ethernet from my router and held in a few inches in front of the lock while adding it, but still got the same result when it added, I will remove it using the exclude function this evening and try to re add it and I’ll get back to you with my result,
Thanks again

I tried everything I could think of in the end and bit the bullet and phoned the lock company who where great and helped me

Turns out the lock is a new version with a few bugs and settings deep inside my Samsung account that needed changing and bingo it all worked, added to alexa simply and now fully working, although I would recommend with the danalock getting the dana bridge as there is more functionality on the app with the bridge in line

Thanks all that jumped in to help me, very much appreciated

1 Like

The danalock bridge is not supported in smartthings though.