Error deleting Hue (Connect): MissingPropertyException


#1

Thanks in advance for any help. I am a brand new Smartthings user and the last 2 days have been a mix of amazement and frustration. When things work, it is really pretty awesome.

Currently, I am getting an error trying to delete my Hue hub. I have submitted a ticket to Smarrtthings support, but it sounds like I won’t get a response until next week and I would really like to get this resoveld before I leave town tomorrow. Trying to delete the hub from within the app, I have been getting the message: “Error: Device still in use…”. But today I found out the “graph.api.smartthings.com” site and found an underlying error that I thnk is causing my problems. When I use that page to delete the Hue (Connect) app, I get this error:

No such property: id for class: org.codehaus.groovy.grails.web.taglib.NamespacedTagDispatcher

Here is a screenshot of the error:


Has anyone else seen somethign like this? Any suggestions that may help point me in the right direction?
Thanks!


(Matt) #2

Generally I’ve found similar issues removing anything in “Labs” However to be sure in the device tile for the hue hub be sure you have no smartapp’s associated to it.

Also there is a good chance you’ll hear back from ST yet today.


#3

Man, I swear I tried this, carefully, so many times over the past 2 days. I got a response from support and they asked me to try once more, so I did and it worked! I have no idea what I missed before, but it looks like I am back in action now.

In case anyone else runs into this:

  • Delete each individual Hue light from the Things page
  • Deselect the Hue bridge from the Hue (Connect) app
  • Uninstall the Hue (Connect) app

Thanks!

obe