Egde Driver Builder - Oops Internal Server Error

Hi!
Anybody else got this problem with the while accessing the SmartThings Developer website using the https://developer.smartthings.com/ url ? I get this Oops Internal Server Error in trying to access the Edge Driver Builder tool, the steps to get there are below. Tried multiple browsers, different computers, same behaviour.

\

Hi, @ellie
I couldn’t replicate the issue but let me ask the engineering team to get more info about what’s going on.

@ellie, following up, could you provide the following information, please?

  1. Confirm the email account registered in the forum is the same one you use for SmartThings. If not, please share it with me over DM
  2. Enable support access to your account:
  1. Go to the SmartThings Web (my.smartthings.com)
  2. Log in to your Samsung Account
  3. Select Menu (â‹®) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.
  1. Replicate the issue, take note of the time of the attempt and share it with us including the timezone, for example: 09:05 GMT-6.
    This is to find the event’s logs and see why it failed.

Hello @nayelyz
Contacting you in private

1 Like

Hi, @ellie

The engineering team was able to find the root cause, it is due to the number of devices in your account. They’ll work on a fix so that’s not a problem anymore. Do you have a device that doesn’t have an official driver match when you pair it to the Hub?

Hello again @nayelyz
Yes I have been having issues with pairing zigbee devices recently, one of them shows as a Zigbee Thing under one of my hub labeled 174, device id 332572c0-5b94-4de9-b9f2-67e7fafd3357

I thought this had to do with fingerprints missing from a community driver. Could it be related to the same issue ?

I see it’s using the Community driver from @Mariano_Colmenarejo called Zigbee Thing Mc, Do you have another custom driver installed for it but it still doesn’t connect to it?
If so, did you verify that the driver contains the device’s fingerprint? I think you can see that info in the device’s detail view of the current Zigbee Thing device using Mariano’s driver.

The issue shouldn’t be related to it because they are different services, we would need to validate the info above first.

hello again @nayelyz
Indeed the device was installed using a community driver which I have a hard time pairing… I will have to try it again since the fingerprints were added recently.

As for my other devices, I have tons of them and pertaining to your question: “Do you have a device that doesn’t have an official driver match when you pair it to the Hub?”
The answer is the same device id 332572c0-5b94-4de9-b9f2-67e7fafd3357 was initially installed not linked to that custom driver from Mariano, so it was unable to pair, from there I decided to try building my own customer edge driver for it, that’s when the Oops Internal server error occured.

Ok, I was asking to suggest you check a custom driver already published in the Community or develop your driver based on one of the existing ones from SmartThings (whose code you can find here). And, I can help you with it.
This is because there’s no ETA about when this could be solved and this would allow you to continue with your process.