[Edge] Wake-on-LAN via Alexa command

If you have a device that responds to Wake-on-LAN commands and you want to initiate those commands via Alexa, then this driver is for you.

From my shared projects channel, install Virtual WOL Switch V1.

How to use it
Once the driver is installed to your hub, initiate a Scan nearby devices from the mobile app, and a new device will be added in your ‘No Room Assigned’ room called vWOL_1. Go into device Settings and configure the mac address of the device you want to control. The SmartThings device will appear as a switch in the Alexa app, so create an Alexa routine to turn the switch on via a voice command. (Note that the switch will automatically revert to OFF after 5 seconds, so you don’t have to worry about resetting it.) When the switch is turned on, the Edge driver will send the WOL command. There is also a button capability included in this device in case you (1) want to invoke it via a momentary button push from a SmartThings automation, or (2) have something in SmartThings triggered based on a button push whenever triggered from Alexa.

If you need more than one of these devices, you can create additional ones via a button in the SmartThings device Controls screen.

Thanks goes out to @DaWeav for the initial request for this driver and testing it.

NOTE:
If all you need is the ability to trigger a WOL command from within SmartThings, and don’t need Alexa integration, you can use my LAN Device Monitor driver instead.

8 Likes

Very cool! :sunglasses:

Tagging @jody.albritton , who likes stuff like this.

1 Like

@TAustin
Your a Beast…I’m sure people will like this.

3 Likes

Thank you again.

‘Alexa, turn on my Computer’, which turns On the Alexa Computer group of devices with the vWOL HP PC, vWOL NAS, and the smartplugs for the miniswitch and computer speakers. I also setup, ‘Alexa, turn on the Telework computer’, which turns on the vWOL business VPN computer. So now I can issue the voice command while I’m making my cup of Tea in the morning, and by the time my Tea is done, I just walk over to my desk and start logging on.

BTW, I went to your Shared Projects channel and installed this driver so I could be on your primary channel driver. When I installed it, SmartThings apparently just automatically switched all of my vWake-On-Lan devices over to it because when I went to your Test Channel, that driver was automagically uninstalled there.

1 Like

You know what I need before I do! Thanks, as always, for the great drivers.

Of note, no surprise here, but this works with Google home devices as well (I have a mix between those and Alexa).

2 Likes

I might be missing something obvious, but I am trying to use this, and I cannot find the device settings, where I should be setting the mac address.

I can install the driver, and vWOL_1 shows up when I scan, but when I tap on the resulting tile (either on my phone, or on the web UI) nothing happens. Normally, I would expect to see the status/settings etc… but nothing opens.

Likewise, I am not sure what you mean by the “SmartThings device Controls screen” if I want to create more WOL devices.

What am I missing?

Hi there. It sounds like you are having some issues with the mobile app. If the device isn’t opening when you tap on its tile, then that’s definitely a problem. How long has it been since the device was created? The reason I ask is that sometimes if you just wait a bit, or restart your mobile app, it can clear up problems like that.

It’s been a few hours. I have rebooted my phone and the st hub, but no joy.

I had WOL working nicely using groovy, but, then … sigh.

@nayelyz Please see issue above: device is not opening in the mobile app. Do you have any suggestions?

@rossc719 - do you have Android or iOS?

1 Like

I’m using Android.

I can still open in both Android and iOS.

I have another SmartThings Hub so I installed this driver today on that Hub. I scanned for devices, and it added the vWOL_1 virtual device. On all of my Android devices (v9 and v12), and my iOS (iPad), the vWol_1 device works just fine in the SmartThings app.

1 Like

Thank you for checking and reporting. I suspect there is some kind of app issue, but you never know for sure…

Not sure where to go from here. Still not working on my end… but apparently it is just me?

Unlike with groovy apps/devices, I can’t see or modify any of the code to to try and ad debugging statements or logs… so I feel kind of stuck and helpless.

(Off topic, but… this kind of thing is strongly pushing me away from ST, and towards something more like Home Assistant… not sure if I want to make that leap yet though).

As I understand you’re only missing the “settings” menu but you can see the device’s detail view correctly, right?
Are you the owner of the location where the device is installed? There was an issue with the app not showing this menu if you weren’t, I’m not aware of the status of that issue…

BTW, my SmartThings Hub I tested on is the V2 model.

In his post here, he’s reporting that he can’t even open the device’s detail view.

Right, I can’t open detail or settings views.
Tapping on the tile does nothing.
And, Yep, I am the owner of the location.

Hi, @rossc719

Can you please share screenshots of the error? I would also need you to send Hub logs and phone logs. Can you please do that?

If you don’t know how to send Hub logs the procedure is the following:

  1. In the IDE, enter “my hubs”
  2. Enter the corresponding Hub and go to “view utilities”
  3. Click on “send” below “send hub logs”

And please let us know which Samsung Account you’re using and if you have more than one Hub, the name of the one where the device is paired. This last piece of information can be sent by DM to me directly, so you don’t have to share it publicly.

If you don’t know how to send phone logs here is a brief tutorial:

  1. Mobile Device Logs | Android Device Logs: Prerequisites - YouTube
  2. Mobile Device Logs | Android Device Logs: Windows - YouTube
  3. Mobile Device Logs | Android Studio - YouTube

Share those files in private as a DM, just in case they have some sensible information.