[Edge migration] Device migrated to a stock driver doesn't work correctly

Hi @Declankh

I take note to do it in the month of August, until then I do not have access to the CLI or a pc

Thanks Mariano, your help is greatly appreciated.

@nayelyz can you comment on this? Looks like the Yagusmart 2 gang switch has been migrated to zigbee switch and child. Is this because there is a match for that fingerprint in the stock driver or has it been force matched on a closest match approach. As noted the stock driver doesn’t work for this switch currently, do you know if that’s likely to be looked at?

The Zigbee Switch driver has some generic fingerprints that check clusters supported by the device and that could have made the driver eligible for this device.
If the device was using a Community-Created DTH, it would match with the process described in this announcement: Next Steps for Community-Created Groovy Integrations

If the device doesn’t work with the stock driver, we would need to see if it’s because it needs a special configuration (which is not included because the device is not certified) or if the basic configuration for a generically supported device doesn’t work correctly.
For that, we need your help to get the driver logs when you send the event to turn on the kitchen strip to see if there’s an error exposed there.

Hi @nayelyz I switched on the log, generated an error even and then did a contact us sending the log, I hope that helps, can you confirm if you got it?

Sorry for the confusion, when you click on “contact us” in the app, your message is redirected to the Customer Support team, so, I won’t get that information.

What do you mean by “I switched on the log”? The logs I need are the ones you can see using the CLI and the command smartthings edge:drivers:logcat, have you use it before?

@nayelyz I used settings → troubleshooting-> create an additional SmartThings log and then sent that withe the contact us and send log option, I thought that was what you meant

ok @nayelyz I have DMed you the output from the logcat command after triggering the kitchen strip from the ST app by attempting to turn it on. I hope that helps.

1 Like

I also have an issue with a Yagusmart 1 gang switch. It’s turning itself off after 1 minute of being on. I’m lead to believe this is because of the Zigbee Switch Driver its using. I’m coming back here pretty fresh. From the looks of it there was a migration from custom ones to ones that kinda match and putting a custom handler in isn’t possible any more? Is this true? Do you know how I can get these working again?

Some devices that were using a Community-created handler started to get migrated as announced here:

That’s why it was suggested that you found a Community driver that would be compatible with your device and install it in your hub so it would be migrated to it.
So, now that is migrated, you can still find a compatible driver to switch the device to it, that’s why, @Declankh asked @Mariano_Colmenarejo for help.

Update about the analysis made with Declan’s case:
This is the expected behavior so far, as the device was connected through a generic fingerprint, we cannot guarantee it’ll work as expected since not all multi-component devices cannot be divided into devices and mapped the same way. So, @Declankh, you’ll need to use a custom driver that is fully compatible with this device.

Dunno what solution is but if you search the forums this issue was reported in the DTH handler

HI Declan H

Did you get any resolution to this - I’ve just bought the same switch and mine has set up as Zigbee Switch not the multi with child. I thought that switching to the multi would work, but it won’t switch over and doesn’t look like it will given what’s written above?

Have you tried the (EDGE Driver-Mc): Zigbee Switch Mc, Zigbee Switch Power Mc, Zigbee Multi Switch and Child Mc from @Mariano_Colmenarejo?

Yes, I got it working with
(EDGE Driver-Mc): Zigbee Switch Mc, Zigb

You need to switch to that driver after installing it on the hub.
Then go into the master device and create the child switch (assuming you want to be able to control both devices independently with Alexa or similar)

1 Like

Thank you so much for coming back to me. I’ve tried that driver but getting the same “Error changing” driver pop up.

Am I right in getting the driver from the Marine Shared Beta Driver channel?

If not where would I get the invitation to the right channel?



Hi @marcobraynio

The fact that you have bought the same commercial model does not mean that the manufacturer or the fingerptints are the same. They are things of Tuya devices.

Install the Zigbee Thing Mc driver from my channel and pair it with it, to see all its data

Hi Mariano

Thank you for coming back to me I installed that driver and the attached image shows the device info - does that help? Can you tell me what I do with that information?

Hi @marcobraynio

Added to this driver version.
Delete old driver version and install the new driver version in your hub
For a best device configuration, I recommends you uninstall device an reinstall with App option search nearby

 Name         Zigbee Multi Switch and Child Mc
 Version      2023-08-02T20:53:25.126707433
- id: "TS0012/ _TZ3000_zmlunnhy"
    deviceLabel: Two Switch
    manufacturer:  _TZ3000_zmlunnhy
    model: TS0012
    deviceProfileName: two-switch

This is a different fingerprint to that in my earlier posting, so would need added to be added to the driver by @Mariano_Colmenarejo

1 Like

Thank you both ever so much for your help - that’s brilliant, working perfectly now both switch and child.