[Edge drivers] Aqara 2/3 gangs switch

Hi can anyone help?,

My 2 way gang aqara switch and 3 way gang aqara switch are not working. i tried to repair my switch on smartthings but it only allows me to the 2/3 way gang switch as a single switch

Hi, @aeonyrs. Welcome to the SmartThings Community!

What do you mean by this? That you have two physical devices, one of 2 gangs and one of 3 gangs.
They stopped working all of a sudden, then you tried to repair them but now they don’t appear correctly in the app?

The OP is probably describing the situation where after automatic conversion to an edge driver a multi gang switch now only has one gang operable. This affected many people because child devices were not functionally transitioned.

There are some community-created edge Drivers for a number of different models that fix this issue, I don’t know what’s available in the stock edge Drivers. :thinking:

Yeah, I thought of the same, that’s why I wanted to confirm if it was a change without his intervention because it could be related to the migration.

It depends if the device was officially supported or not, we would need the device fingerprint to confirm it.
@aeonyrs, if it’s a Z-Wave device, could you provide its model to look for it in the Z-Wave products catalog, please?
If it’s a Zigbee device, could you enter the Advanced Users app - Devices, enter the device’s details and share with me the values in “Manufacturer Code” and “Model”, please?

1 Like

The OP said Aqara, so that would be a Zigbee device.

They have announced some thread switches, but they aren’t available yet, and all their other products are Zigbee. :thinking:

Hi,

yeah my multi gang switch now only has one gang operable. Im using aqara smart wall switch D1 with neutral. it was working fine until 1 week ago

Hi,

May i know the switches are not working due to an update in the driver? Any place where i can read up more on it?

It’s multiple models, it just depends on how they were configured.

Here’s a recent thread discussing the issue:

3-gang lightswitch child switches not accessible

Hi @aeonyrs please can you help us with the following to investigate?

  1. Can you share the model of your devices?
  2. Enable support access to your account:
  1. Please confirm that the email address that you use in the community is the same as that in SmaertThingsm if not, please send us by private message
  2. Go to the SmartThings Web (my.smartthings.com)
  3. Log in to your Samsung Account
  4. Select Menu (⋮) and choose Settings
  5. Toggle on Account Data Access
  6. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.