[Edge Driver] RTCOA CT50 Wi-Fi Radio Thermostat

Filtrete 3M50 Wi-Fi Thermostat

If you happen to have an RTCOA Wi-Fi Thermostat model CT50 (it was also sold under Filtrete 3M-50 brand), you’re invited to participate in testing of a SmartThings Edge driver available from my Edge Driver Test Channel.

This is a remake of my original Groovy DTH with some improvements, particularly autodiscovery, i.e. you no longer required to enter the thermostat IP address during installation.

Please note however that should the IP address of the thermostat change after the SmartThings device had been added, you would have to delete the device and re-add it again. It is therefore recommended that you reserve the IP address for your thermostat in the Wi-Fi router settings to ensure that it does not change after your thermostat and/or the Wi-Fi router is rebooted.

I’ve replaced the Groovy DTH with the Edge driver and been using it for a few days now without any issues. If you experience any issues, please let me know. Your comments and feedback are welcome.

Here’s a screenshot:


Very interested, especially now that the radiothermostat app is about to die! I have 2 on my local Wifi, so this should be interesting, especially since I’ve been dragging my feet with leaving groovy, including your original DTH, and this will be my first foray into Edge Drivers. I followed the link over to your test channel, enrolled, and installed the driver… now I’m off to google where to go from here. I’ll get back to you.

I removed the old handler and device through the old graph API and confirmed the new driver is on my hub and the old driver is gone through the smartthing app. I also verified that both thermostats are still on wifi via ping. When I attempt to add a new device by scanning in the smartthings app, it finds nothing. What’s the right trick to getting the device added?

This morning I thought I’d poke at it a little… I found one of the thermostats had been added back, with the old name still assigned, and no room assigned. I removed it again through the app, and it appeared again, but the other thermostat is still not showing up.

Okay, thanks to the CLI and logstat, I see that it was “reappearing” because I had done another scan… the scan comes back and says “no devices found”, but it does in fact find a thermostat and puts in the “no rooms assigned” category quietly. Running the scan a second time, it picked up the 2nd thermostat as silently as the first.

So now I see both thermostats successfully. Next up, I can poke at scheduling locally through the 3m-50’s API, unless it’s in your plans to include that in the app! I mean, I guess it could be done through routines, but that’s rather clunky.

because… because, because, because! Because of the wonderful geek I am!

https://lowpowerlab.com/downloads/RadioThermostat_CT50_Honeywell_Wifi_API_V1.3.pdf is the API docs that are readily available that came up quickest in my googles. Section 2.2 is the relevant section.

.152 and .153 are my two thermostats.

gimblox:~rick$ curl

substitute heat/cool and mon for any day’s TLA for reading schedules. That’s enough fun for the day, I’ll leave the setting of schedules to the reader (or me, at a later date).

1 Like

Glad to hear it worked for you. Yes, a newly added thermostat will appear in the “Unassigned” group. I have only one thermostat, so can’t really test discovery of multiple devices.

I don’t have immediate plans to implement scheduling as I don’t see how it can be meaningfully incorporated into automation routines. Personally, I hardly ever change the schedules and I’m perfectly fine doing it in the native app.

@geko - Just a note of thanks. I am really happy with my CT50 hardware and didn’t want to walk way from eleven thermostats in three locations. Your Edge Driver for SmartThings works great. I didn’t even realize my Samsung TV could work as a hub, but it does. Once I set that up and added your Edge Driver, the first thermostat just appeared. Next best thing to magic. It would be super helpful if it continued searching for tstats after finding the first one, but powering them down and adding them one at a time does work. I also need to change them over to static IP or reserve DHCP address for them, but again, that’s a small price to pay. So, again, thank you so much for building this!! (Now, if IFTTT would just re-enable SmartThings support, I could really have some fun…)

1 Like

Owning 7 of these, Happy to find this thread. More later. !!!

I’m installing the driver but can’t seem to connect to the thermostat. Any suggestions?

@geko I also just installed the driver but quite a novice at adding things not through the add device wizard. Can you provide instructions? Should it just show up on my app?

1 Like

I got two thermostats connected—they just showed up—but my third one is being stubborn. I have cycled the power on it and tried adding through the app to no avail. Any ideas?

Did you get it to work?

I had deleted my RT from SmartThings but would love to use this edge driver. I have accepted the invite and see the new edge driver from my app and it looks like it is on my hub as well. How do I get the RT re-added to SmartThings using this edge driver?

Hi, thank for the efforts. Works great. I have almost 30 CT50 thermostats in multiple locations. Can you share the code for the driver? I would like to add “Hold” and “Vacation” buttons and may be some info.