(EDGE Driver-Mc): Zigbee Switch Mc, Zigbee Switch Power Mc, Zigbee Multi Switch and Child Mc

(NEW RELEASE) New version 5.5 of Zigbee Switch Mc and version 3.0 of Zigbee Switch Power Mc:

Improvements and fixes:

  • Added Groups functions:
    • Added identical functions as Zigbee Light Multifunction Mc version 5 driver
  • Reduced the use of permanent memory to the on and off of the switch, in the Zigbee Switch Mc driver, when using the simulated consumption measurement functions

As the driver has a new Capabilities, profiles and changes in preferences the update will not be done automatically .

To facilitate the update, I am going to change driver version 5.0 to the name Zigbee Switch Mc- (OLD).
The VersiΓ³n 2 of Zigbee Switch Power Mc-(OLD)

I will publish the new version 5.5 with the original name Zigbee Switch Mc
The versiΓ³n 3.0 Will be named Zigbee Switch Power Mc

In this way, your driver installed will renamed with (OLD), indicating that there is a new version available and you can install the new version with a driver change whenever you want.

β”‚ Name        β”‚ Zigbee Switch Power Mc               β”‚
β”‚ Version     β”‚ 2022-01-26T18:22:17.045126           β”‚
β”‚ Name        β”‚ Zigbee Switch Mc                     β”‚
β”‚ Version     β”‚ 2022-01-26T18:35:21.940848           β”‚

Thank you!! :stuck_out_tongue_winking_eye::tumbler_glass::tumbler_glass:

1 Like

Why am I seeing 2 different drives with the same name?
Zigbee Switch Mc one installed and one to install


1 Like

Thanks for letting us know!

@nayelyz, This is the second time it has happened. On the Web the name is wrong and on the CLI I see it right, one is -(OLD) v5 and the Mc is v5.5.
It is fixed

β”‚ 22 β”‚ Zigbee Switch Mc                            β”‚ 7fb1b4d8-d21d-49f3-9f4a-017e2bf7e888 β”‚
β”‚ 23 β”‚ Zigbee Switch Mc-(OLD)                      β”‚ fea7bb98-51a2-4a1e-a4c6-62761bfdb17c β”‚

@Mariano_Colmenarejo, are you in the same situation as @Diegocampy?
It’s weird, I’m not seeing the same, I see the correct names.
If you are seeing the same, have you tried to clear the browser’s cache and see if it is solved?


Yes, now is correct due to I published it agains to fix it.

The Name was changes yesterday and in CLI always was correct as can see in the my cli capture.

β”‚ 22 β”‚ Zigbee Switch Mc                            β”‚ 7fb1b4d8-d21d-49f3-9f4a-017e2bf7e888 β”‚
β”‚ 23 β”‚ Zigbee Switch Mc-(OLD)

This happened a long time ago with another driver, a long time ago, I would have to look for the post

Ok, I’ll create a report about that, maybe the team could check what happened, I can look for the other post, don’t worry.
Could you share with me the channelId and the invitationId, please? (a direct message is ok)

Hi, Sorry, maybe i’ve missed this but where can I actually get the code for the Zigbee Switch Mc device handler…?

To clarify, it is not a device handler, DTH.
It is an edge driver, which replaces DTH.

you can install it on your hub from this link


Oh awesome, thank you! I’ve enrolled and installed the Switch Power MC, are there any tutorials on how I now use this for a given Zigbee device? Thanks

I confirm, I saw the correct drive only after you have updated :+1:

I don’t know if there is any user tutorial, this is the link to official post

But I’ll tell you the main thing:

  • The first thing you have to see is if the fingerprint of the device you want to use with an Edge driver is included in that driver.
  • You must enter the IDE and see its fingerprints, especially the exact manufacturer and model
  • This is not well resolved at the moment, I am updating the lists of supported devices in the header post, but they are not always up to date, since they are added continuously.
  • There is also the official smartthings Beta drivers channel with many drivers and there are also no lists of which devices are supported.
  • A clue not always reliable is that smartthings is including in edge driver the devices that are supported by stock DTH, but the name of the DTH does not have to match the name of the new edge Driver. For example, in the Beta stock smartthing Zigbee Switch driver there would also be plugs, switches and dimmers with and without power measurement, light bulbs of all kinds… and many more.
  • There is a link to the smartthings github where you can see the file that contains all the drivers and their fingerprints files where all the supported models are.
    GitHub - SmartThingsCommunity/SmartThingsEdgeDrivers
  • This is how to see them:
    • Enter the link click on code and on folder click drivers/Smartthings

    • You will see the folders that contain the drivers, by name

    • Open the one you want to see

    • Look for the fingerprints.yml file and open it

    • Search to see if the model of your device is there. You can press F3 and write the name in the search field

    • If your device is supported, go to the smartthings channel

      SmartThings. Add a little smartness to your things.

    • Install the driver in your Hub

    • Uninstall your device with the App

    • Add new device and tap search nearby

    • The device will be paired with the installed driver instead of the DTH

    • If it doesn’t pair, it means that you were using a custom DTH and you should uninstall it from your IDE or modify the DTH so that it doesn’t see your device’s fingerprint, writing // at the beginning of your device’s fingerprint code line.

I opened left something, but this should be valid for almost all cases and hopefully it will improve when the Beta phase is over

1 Like

Amazing! Thank you @Mariano_Colmenarejo

Managed to get this working via the Edge driver but do not see any power /energy information. Is there a separate bit of Config I need to do?

It should start sending power and energy consumption data when you turn it On…

Wath model is?

I’ve got some IKEA Tradfri GU10 and E27 bulbs which I’ve removed and then re-added using the v5 Edge driver. The bulbs all work - they switch on/off, colour temperature, progressive features etc.

However, I’ve noticed the state doesn’t automatically update in the ST app - as in it doesn’t show the bulb has switched on or off even if it physically has. I keep getting network errors. If it shows as on (but it’s off) then a double tap on the power button within the app does switch it on again.

Is this β€œexpected” behaviour with the state of the beta at the moment or does it sound like something’s not right? How can I diagnose where this is a problem?

BTW, the hub is pretty close and I’ve got a number of Zigbee devices working fine (and they were on the old DTH).

They should sync well with the app.

If it happens with all of them, it could be that there is a problem with the smartthings servers in your area. The information to the app passes through the platform’s servers.

If it is a specific one, it may not have been installed correctly with the driver and it could be solved by reinstalling

Thanks. It seems like the status of various bulbs using this edge driver (I’ve just moved 5 of them over from DTH) is very temperamental at the moment. (Nothing on ST service status, but that of course doesn’t mean it’s working properly).

I have a routine which is marked as being β€˜local execution’ as all the devices in it are using edge. This routine isn’t working properly either - with one of the lights not responding to the routine (manual control is working) and another which is already off, has been set to turn off only in the automation, but comes on for half a second then goes off again.

Perhaps I should restart my hub?

Yes, try reboot it to see if it is solved
it’s a bit weird, there are users who are complaining about smartlighting automations

A reboot didn’t help.

I haven’t used smartlighting automations - just a regular custom one, but it could perhaps be part of the same problem.

The inconsistent device status with Edge is strange. I am not seeing this with DTH. Annoying that the IKEA bulbs are not fun to reset, especially with having to re-do any routines afterwards (since they have to be deleted and re-added).

I have tried mine and the three I have work well, 2 from lidl and one osram

In order not to lose the automation, use a virtual device, which you insert where the light bulb is, so the automation does not disappear when uninstalling.
Then you replace the virtual device with the bulb again

1 Like