(EDGE Driver-Mc): Z-Wave Edge Drivers and others with FIBARO devices:

Thanks for the manual.
Ok, first I’ll try with the buttons. If it doesn’t work I’ll remove the buttons cover to access the device directly.

Just to clarify: If the exclusion works, the device will just disappear both from the App and IDE, correct?
If so, it’s easy to see if it works or not.

The exclusión prosess:

  • First with the app you have to enter the hub.
  • In the 3 dots menu, top right select z-wave utilities.
  • select exclusion z-wave

  • Perform 3 click on device S1 or button B
  • The exclusion process starts and you will see the result when it is finished.
  • If it says the device was excluded, it will disappear from the app and IDE.

If you don’t want to lose automations:

  • open each automation or scene where the device is and replace it with another, virtual or real device
  • When you reinstall the device, replace the FGR-222 with the one you temporarily added.

Hello @Mariano_Colmenarejo.
Using the buttons worked! I was abble to exclude and include the device.

But now I have a problem: I order a calibration and it was made ok. If I open to 100% → OK. If I close → Ok. But if I try to change to a % value (different from 0% and 100%) it doesn’t work!!!
The strange thing is, when I choose the value, I can hear a click on the device, but nothing happens…

Can you help me?

Not happy with the result… Just made another calibration and now it works! I can choose the % I want. Don’t know what happened…

One question: Is there a way to refresh? If I change to another % the app doesn’t show the correct %. And even if I swype it doesn’t update the value.
For example, about 3 minutes ago, the value was 65% and I gave the “Open” order, so since 3 minutes ago, the correct value should be 100%, but in the app i’m seeing 94%

I don’t have these devices and I won’t be able to help you much.

Do you have the adjustment of parameter 10 in blind with positioning?

Just updated my post after your response :slight_smile:

As I told you, I don’t know how they work since I don’t have one.
There are several ways to detect the limits, by motor consumption, by switches, I don’t know how your installation is.

There are several configuration parameters to adjust the detection and stopping limits.

The % that the app shows is what the device sends to the driver, if it does not match the real position of the blind, it must be some configuration or calibration.

Maybe other users who use them can help you more.

The only thing that the driver has added to the edge default handling is the sending of the configuration parameters to the device.

The device is responsible for managing the operation based on these parameters.

Sorry I can not help you anymore

1 Like

Quick Question about the Fibaro-FGS223 integration that got includes in the official channel
I used it to add a double switch to the network but in the app all i can see is only 1 device for the main switch.
Is that how it is suppose to work ?
I want to be able to control both lights separately.
It seems that the driver itself allows for as i see main and switch 1 and can open them separately.
Is there any way to create a device from the second channel as the official DHT does it?

Just create a virtual switch for Switch 1

1 Like

I added 4 Zooz Zen 72 Dimmers and 1 Zen 71 Switch this week, I already have 3 Zen 72’s installed using @krlaframboise Zooz ZEN72 700 Dimmer VER. 1.0.1 DTH.

I was surprised after I was finished and went to edit the names that they had all installed using @Mariano_Colmenarejo Z-Wave Switch Mc

I do not have // in front of the of the fingerprint line as described below.

“If you’re currently using my Groovy DTH for the device then you’ll need to either uninstall the DTH or put // in front of the fingerprint line near the top of the code because the ST onboarding process only looks at the installed Drivers if it’s unable to find a matching fingerprint in a custom Groovy DTH.”

Has the Edge driver priority changed?

Just curious/pointing out my observations.

I don’t know if anything has changed or not.

The Mc driver just like the stock beta driver has two generic fingerprints for switch and dimmer, that may be the reason why it is paired to the driver instead of the DTH

How do I do it with EDGE drivers?
it would make no sense to use the API to do it if the plan is to disable the API at the end of the day.
Can anyone share a guide ?

Here are links to two virtual device drivers, I use the one by @TAustin , so I cannot comment on the second one.

This Works great
Thank you very Much.
I would still prefer if this child will be created when the Driver finds the new device but this is a nice workaround.
Thank you @NickA for your help

If it is for a dual FGS223 switch, I would use the stock driver from the smartthings beta channel.
I would only use the Z-Wave switch Mc driver if you also have devices that are not included in the stock driver.

The stock driver Z-Wave switch will be updated automatically until the beta phase ends and the definitive version comes out.

  • Just install the stock driver on your hub.
  • Enter the device details view
  • Go to menu 3 points, top right and select driver
  • Select to use another driver. It will propose the compatible ones, the stock Z-Wave switch
  • Click on use this driver and wait 1 minute for it to install

You only have to change the settings that you have modified in preferences.

I’d like to sincerely thank you for your work, and for work I didn’t think would, or could ever be done. I know manufacturers would prefer users to upgrade and spend even more money on new devices, instead of this, you have breathed new life into once obsolete devices, it’s nothing short of remarkable. In two years you’ve done demonstrably and quantifiably more to help users than anyone else on the forum since it started. Even more so is the selfless way and lack of renumeration and praise needed, that make your efforts so sublime. It’s hard to quantify just how much money you’ve saved me personally, and as a community, both in devices and in batteries (with your ground breaking power reporting tweaks of local devices). There are too many impactful ways you’ve helped to mention, also without the physical device itself to work on or enjoy yourself, like the Fibaro RGBW Controller with it’s inbuilt animations like “Fireplace” and “Storm” that are finally able to run locally for the first time ever!


Thank you for your words!!

I am glad to know that this is useful for other users of the community :+1:


Good Evening.
Have you tried to implement the fibaro motion sensor driver?

Fibaro Motion Sensor ZW5 :

zw: Ss type: 0701 mfr: 010F prod: 0801 model: 1001 ver: 3.02 zwv: 4.05 lib: 03 cc: 5E, 86,72,59,80,73,56,22,31,98,7A sec: 20 , 5A, 85,84,71,8E, 70,30,9C

Hi @GiacomoF,
This one is among the half-done in the stock beta Z-Wave Sensor.

They’ll post it soon I think!

1 Like

The Fibaro Single Dimmer seems to be working much better now. S2 is working perfectly and being able to distinguish between on/off with pressed/held for a physical toggle switch means I can very easily set up a local automation to control other non-load devices from this toggle switch. This is really, really good.

I have noticed for S1 that there is no setting to synchronise with the physical switch. The Fibaro’s have parameter 22 to control this. This would mean, for a single physical switch installation that down is always on and up is always off, instead of acting like a 2-way switch with the Fibaro being the ‘hidden’ 2nd one. (Of course, this means if the physical switch is down and the lights are off, then toggling it up would mean they’d stay off and then would only come on if toggled down).

Would it be possible for you to expose this in your driver, rather than having to use a Z-Wave tweaker?

Otherwise, I don’t know what’s changed since the last time I tried this a few weeks ago with the same dimmer, but it’s so much better now. Reliable, working correctly from what I can tell and the S2 is great!

Oh, and whether this is a driver thing or a ST thing, it seems this works properly when both buttons are toggled together or very similar times. This didn’t work very well with the DTH + scene control + WebCore (it was quite unreliable anyway, but especially if both buttons were pushed together).


Yes, I added 2 buttons to be able to execute with automations and scenes the actions sent by S1 (Button1) and S2 (Button2) when activating parameter 28, sending scenes, according to the table in the manual.

the only thing that didn’t work well is that S2, by default also controls the load connected to S1 and it shouldn’t. I already reported it to @nayelyz

I have added parameter 22 for the option to synchronize the device state with the mechanical switch.

The changes are in this version

│ Name        │ Z-Wave Switch Mc                     │
│ Version     │ 2022-03-06T10:45:23.484229           │