Ecolink Z-Wave Motion Sensor - now showing up as Z-Wave Door Contact


(Tuffcalc) #1

I have an Ecolink ZWave motion sensor that has been working flawlessly for some time. Now all of a sudden its acting weird … so I removed it (excluded). Now whenever I try to re-add it, it will only show as a Z-wave Door contact sensor.

Has anyone seen this behaviour before?

Thanks


(sd ) #2

I had the same issue as well. I had to go to the ide and change the device type. It has been working fine since then


(Tuffcalc) #3

Have you noticed that the 4 minute delay is now gone? When I changed the device type back to zwave motion sensor in the IDE (just as you have done), it doesn’t “act” like an ecolink anymore. It acts more like a Smartthings Motion Sensor - no delay.


(Tuffcalc) #4

I noticed now that the 4 minute delay is gone from the Ecolink PIRZWAVE2-ECO

Smarthings - have you made a change so that this sensor now acts similar to the Smartthings Motion Sensor? I can confirm the PIR is not on “test” mode.


(sd ) #5

That’s interesting! What was the device type you selected in ide?


(Tuffcalc) #6

Device selected in IDE is ZWave Motion Sensor.


(Jared Pomranky) #7

I just bought a new hub and an ecolink motion sensor and I’m having the same issue. It won’t add as an ecolink motion sensor after multiple tries and only adds as a window/door sensor.


#8

I am new to SmartThings. Was able to pair several devices, Including two Ecolink Door Contact. But when it came to Ecolink Motion Sensors, they all tried to pair as Door Contact.

In anticipation of wonderful compatibility, I bought 6 Ecolink Motion Sensors. Tried 2 and both failed. Not so happy. Reconsidering SmartThings as the central hub.

Successfully paired:
o Ecolink Door Contact - qty 4
o SmartThings Presence - qty 1
o iPhone 4S
o FortrezZ SSA1 siren&strobe alarm


#9

@JaredDetroit and @wolfstone The reason ST doesn’t see it right could be for several reasons. Reconsidering the hub just for this is going a bit extreme IMHO.

I have several Ecolink devices, from door/window sensors, to motion sensors; and all have been a PITA for the most part out of the box. I just got into the habit of doing an exclude before even trying to include them.

With regards to the motion sensor, you can call support to have them change the device type for you, or you can go into the IDE (developer tools) and change the device type yourself.


#10

Thank you for the info, @johnconstantelo.

My ST hub sees the Ecolink Motion Sensor seconds after I attempt to include it. The problem is that it identifies it as a Door Contact. This happens even when I explicitly say that the device that I am about to include is E.M.S.

From previous rummaging around, it appears that the Ecolink Motion Sensor worked well with SmartThings until recently. Perhaps a recent software update induced the problem.

I will try another unit and poke around in the IDE, which I haven’t touched yet.

Since my previous posting, I have added:
o SmartThings Moisture Detector
o SmartThings Motion Detector

As a beginner, I now have 9 devices paired with the ST hub. The ST Motion Detector didn’t identify as the correct model, but it did identify. Only the Ecolink Motion Detectors won’t pair as the right type of device.

Next up: A few more doors and windows.

But after that, I have to get the Motion Detectors running. IDE, here I come!


#11

I have added an Ecolink tilt sensor (garage door).

I made more attempts to include the Ecolink Motion Detectors. They still identify as Door Connect. Then I started playing with the IDE.

It appears that any specifically named support for Ecolink devices is gone. Instead, any Ecolink device that I include is identified as generic Z-Wave - usually of the correct type.

Total guess here: Ecolink devices are so standard that there is no point in calling them out by name. There may even be political/licensing/marketing reasons to not call them out by name.

I am OK with this, so long as they identify as the right type of device and function properly.

The problem is that the Motion Sensors do not identify as the correct type. Furthermore - previous postings suggest that, even if you use the IDE to change the device type to the generic Z-Wave, special features like the 4-minute delay switch don’t work.

Total guess #2 - In an attempt to present all Ecolink devices as generic, somebody forgot that the Ecolink Motion Sensor offers more.

I appreciate the assistance of other Community members. But can somebody from Smart Things support get involved?


(Greg Fountain) #12

You need to open a ticket with support. I purchased an Ecolink motion sensor, and it too was registering as an open/close sensor. I emailed support, they worked their magic, and it finally showed as a motion sensor.


#13

Thank you for the suggestion. Actually, I don’t need the tech support myself - I was able to use the IDE to change device types, so my Ecolink motion detectors are now treated as generic Z-Wave motion detectors. Certainly a step forward!

My mention of SmartThings support is about the larger issue of Ecolink-specific features that may be unavailable, according to @tuffcalc

@Ben has contacted me and says that this is being investigated.

Thanks again, everybody!


(Tuffcalc) #14

@wolfstone - I may just have a bad Ecolink sensor, as I purchased a new one and it has the 4 minute delay when installed as a “Z-Wave Motion Sensor” using the IDE. In any event, my “bad” sensor may actually be benefit … no 4 minute delay and so far no appreciable battery loss after a few weeks (still at 100%).


#15

They fixed it…I think.
I just added a new Ecolink Motion Sensor. It was initially recognized as a switch; however, when I went into the IDE - it was already listed as a motion sensor. I restarted my Android and sure enough…it was listed as a motion sensor.


(HousePanel Author) #16

I have the exact same problem and I don’t know how to use the IDE. Can someone help?


(HousePanel Author) #17

Update – I did the same thing as Katch and had the same result. Figured out how to get to the IDE and it showed as a motion sensor. I just updated and didn’t have to restart iPhone. Just refreshed screen and now it shows as a sensor. This is a bug that the ST folks should fix but I’m glad I found a workaround.


(Jeronimo Bohorquez) #18

I managed to change the type of sensor to a movement sensor, but now the ST app shows that he sensor is always sensing movement. How could I correct this problem?


(Kim Andrè Flaten) #19

I have this problem after setting up with the new hub v2, change in IDE to motion but its not working, any tips to fix this?


(Steve) #20

Ecolinks have always been great for me. I have 7 of them right now. THEN Last week I attempted to pair 2 Enerwave Ceiling Mounted Motion Sensors. After 3 hours of monotonous torture, I got ONE functioning properly as it should using Adam Heinmiller’s Device Type. The other just wouldn’t pair properly (constant motion issue). I returned it to Amazon.

NOW, today I’m installing another Ecolink (the old trusty favorite) and its being discovered as a friggin enerwave ceiling mounted (Garbage) Motion Sensor. I’ve changed it in the IDE manually, and its NOT WORKING. Now the ecolink is behaving like an enerwave piece of garbage and showing constant motion. Ive unpaired and repaired 10X and keeps happening. I don’t get it.

I have a V2 hub. I transitioned to V2 from V1 last month. I have about 90 devices on my account and have been monkeying with ST for about a year. This really needs to be made more user friendly if they’re ever going to attract a mainstream following. I consider myself tech savvy and handy, but I’m by no means a computer guy and I don’t see how a run of the mill layman would ever be able to use ST.