Ecolink Motion sensor stopped working


(Iraj V) #1

I bought a pair of Ecolink motion censors along with my Smartthings hub. They were both working fine until yesterday. I noticed that one of them is showing motion, when there is none. After waiting some time, it became clear that it’s got stuck on motion. I removed the battery and put it back in about a minute, still no change. Then I removed it from the hub, and tried to add it again. It wouldn’t pair up. It started searching, and showed “identifying …” message on the screen, but got stuck there.
When I went back to my “Things”, it showed me a new Zwave door open/close device, which was open! I tried this process a few times, with the same results. I even once forced deleted the device. Still the same…

Any idea how to deal with this?!


#2

You probably need to go into the IDE and change the device handler of your “Zwave contact” back to a Zwave motion device handler.


(Iraj V) #3

I did that too. What happens is that it changes to motion censor, but again, always in motion mode. Back to square one!

Any other ideas?


#4

I would first try to do a z-wave exclusion, then re-pair but with the motion sensor within a couple of feet of the hub.

After that, you might want to try rebooting your hub, and if that doesn’t work, do a cold start by taking the power out (and remove batteries if v2 hub) for about fifteen minutes and then reconnect.

Finally, do a z-wave repair. Hopefully that will bring back your motion sensor.


(Iraj V) #5

Hello,

Thank you for your response. I finally got some time to do those steps, unfortunately with no luck. Every time, it recognized the device as a door, which is always open!

Is there anything else I can try?

Thanks again.


#6

Hmm, I’m sorry but I’ve exhausted all my suggestions, the only other thing that I can think of is to replace the battery or try a different motion device handler even if it is not designed specifically for an Ecolink.

It’s possible that its gone bad. Have you contacted support? Maybe there is something that they can do on the backend.


(Stephen Ross) #7

Im telling you, the developers and UX designers working on SmartThings Im not sure what they are doing, the process is so convoluted and nothing works properly but here is what I found. To get your EcoLink motion sensor to work it has to be set as a motion sensor, not a door sensor. Strangely, almost everything you do with the Smartthings devices needs to be set up in your smartthings account online which is not at smartthings.com you have to go here. Actually just type in SmartThings Login on Google and click the link. It will take you to a site that looks like this: https://graph-na02-useast1.api.smartthings.com but for your area. Do not click on that link if it’s not your area. Then you go into your account once set up if you dont have one already and you need to change your device type using the edit and update feature change it from door sensor to motion sensor. Then if you pray and dance 3 times around a circle it might actually start working. Actually I found the link: go here: https://graph.api.smartthings.com/

Stephen