Ecolink Motion Sensor detected as door/window sensor


(Arun Nayar) #1

I had good success with the ecolink motion sensors so I bought 2 more. Yesterday I tried to set them both up and both of them got detected as door/window sensor. I looked up here and saw posts from 2014 where people had same issue. Changing the device type to Zwave motion sensor in IDE seems to fix the issue but any idea why this is happening?


#2

The same fingerprint is being used by both devices more than likely.


#3

They share the same fingerprint. Our system first types it as a door/window sensor, then detects that it’s a motion sensor and changes it. We’ve seen in some cases that the second retyping doesn’t happen. In most cases you can simply wait a bit and re-pair it, but changing the type manually should be fine too.


#4

have the same problem. let me try this workaround.


(Mike Kelley) #5

How do I change the device type in the app? I don’t see a way to do this.


#6

This is done through the IDE website:

https://graph.api.smartthings.com


(Mike Kelley) #7

Yeah, that doesn’t work (it says it doesn’t have a hub for me connected, even though it’s obviously connected in my app).


#8

Did you register using the same username and password? It’s been a couple years for me, so I can’t remember for sure. Email support otherwise. The IDE is tool you’ll want to use more often than you think.

Is there a button/link to add your hub? Again, I can’t remember for sure.


(Mike Kelley) #9

Actually I was able to get it linked by going first to “My Locations” and then it saw me and my hub (another user here posted that on another thread).

I did eventually get another link to go to the IDE/API from support email – apparently the link he gave me at first was only for users who have gone there and linked stuff up once, and if you are brand new you need to visit this other link. But at least I got there and got things all straightened out.


(Yangers Puentes) #10

If I change the device type should be to z-wave motion detector? I don’t see any Ecolink in the list.


#11

Yup, that’s all you need to do.


(Kim Gustafson) #12

I ran into this same problem recently after having my hub replaced. The Ecolink was detected as a motion sensor with the previous hub but a open/close sensor with the new hub. I changed the type of the device in the IDE to a Z-Wave Motion Sensor, and now it seems to be stuck in “motion” mode. It never changes to “no motion”. There are also NO events in the IDE for the device other than the initial battery level event. The device appears active in the IDE. Have others experienced this issue?


#13

I have this exact issue. The battery also drained from 100 to 42% in a few hours.


(Kim Gustafson) #14

Just as an update, I’ve been going around in circles about this motion device. Support claimed to have fixed the device on their end (no doubt just did the same thing I did which was to change the type in the IDE and rename it) and asked me to do a hub reboot and a battery pull on the device. Now the Ecolink just displays a red LED indefinitely and doesn’t detect any motion.


(Kim Gustafson) #15

Support finally just referred me to Ecolink. Basically said they couldn’t do anything since it’s not a ST device. In summary:

  1. Hub firmware update (which as a user I have no control over) bricked the hub
  2. Replacement hub sent
  3. Reconfigured all devices
  4. Ecolink doesn’t configure correctly with new hub (worked fine with previous hub)
  5. ST support can’t do anything about it and referred me to Ecolink

Haven’t had a fully working system again after 6 weeks.

Nice firmware update.