Ecolink PIR Motion Sensor Won’t Pair

I just bought my second Ecolink PIR motion sensor and can’t get it to pair with my SmartThings hub. The instructions are very simple:

  1. Remove the battery tab in the sensor
  2. In SmartThings, add new device

But it never detects it. It just sits there. I’ve tried unplugging my smartthings hub, disconnecting/reconnecting the battery in the sensor, but no luck.

I don’t remember this much trouble when adding my first ecolink sensors a couple of years ago, but it’s still working great, which is why I bought another one.

Is this a defective sensor or am I missing something?


Two things to check

  1. ecolink does make sensors for different Z wave regions, and the region of the sensor must exactly match the region of your hub or they won’t be able to talk to each other. What’s the model number? And where did you buy it?

  2. speaking as a former field tech, typically the first thing we do when a Z wave device won’t pair is to do a general exclusion on it just in case it was previously paired to a different network. It might’ve been a return, or it might have been paired to a test net work in the factory and didn’t get cleared properly. It happens. :man_shrugging:t2:

I’ll leave it to other people to explain how to do the general exclusion.

1 Like

Hi there JDRoberts, thanks for your quick response!

I bought the Ecolink Z-Wave PIR Motion Detector Pet Immune, White (PIRZWAVE2.5-ECO) on Amazon

Maybe it is paired with another device. There’s a tiny hole, which I assume is for a factory reset. I pressed it for a good 30 seconds and tried adding it again. It didn’t work.

Thanks so much for taking the time to respond!

Can anybody explain how to do a general exclusion?


Tagging @jkp

there are two paths to excluding a z-wave device:

  • option 1.
    In the St app, locate your hub tile, open it, tap on the 3 dots in the upper right of that screen, choose settings and go to z-wave utilities.
  • option 2.
    use the Advanced Web App. go to the hubs section, tap on the name of your hub and the z-wave exclusion button is near the top of that screen.

Put your hub in exclusion and follow the steps needed to exclude… usually it is either pressing a button on the device or removing/reinserting batteries.

If I understand it correct, a Z-Wave exclusion is to have it remove the item it detects on the network when I put the batteries in (or press the pair button). But my problem is I haven’t been able to add it yet on my network. The hub never detects it.

I just tried the exclusion anyway and put the battery back into the motion sensor, but not sure what it’s supposed to do since the device wasn’t there to remove in the first place. lol

I’ll try adding it now and see if it can finally detect it.


That worked! I noticed an immediate difference after doing the Z-Wave Exclusion: When I put the battery in the light started blinking! It didn’t blink before, which I guess means it was paired like JDRoberts said. I thought that was strange that a z-wave device didn’t blink when trying to pair, and now I know why it wasn’t!

Thanks for your help you guys! I really appreciate it!



Not exactly.

The purpose of a device specific exclusion is to tell a device which has already been connected to the network to clear its network information (stored in the firmware of that device). So for the specific exclusion, the hub and the device do already know each other.

The purpose of a “general exclusion,” in contrast, is to broadcast a “reset network settings” instruction, so that any zwave device in the vicinity, whether it has ever been connected to that hub or not, will hear it. Then, if, and only if, a device has been put into exclusion mode (as @jkp said, that’s usually with a specific tap pattern on the buttons of the device itself) that device will then reset its network settings, even if it never belonged to the broadcasting hub’s network. The end device doesn’t care what network the hub is on. It’s just going to do essentially a factory reset on its own firmware as far as the network fields are concerned.

At that point, the device will be ready to add to a new network, which could be the one that issued the general exclusion or an entirely different one.

The point is that the people who created the independent third-party Z wave specification understood that there might be times when the hub which previously owned the end device was no longer available. Maybe the hub itself had failed, maybe the device had been bought used, maybe, as I mentioned, the device had been set up on a testbed at the factory, but not properly reset before shipping. It doesn’t matter. They provided the “general exclusion“ utility as a way for any certified Zwave hub to tell any certified Z wave end device to reset its network settings.

So that’s why it’s usually the first troubleshooting step if A zwave device won’t add. :sunglasses:


Thanks for such a thorough response. I understand it quite a bit better now. I appreciate you taking the time for such a great explanation!


1 Like

I can’t get this same sensor to pair with my SmartThings v2 hub. Any assistance would be much appreciated. I have added pics of the unit and identification information.

I can only send 1 pic per post so here is another. I bought this years ago and never set it up. Adding a battery turns on a green light that never goes out which apparently means the sensor isn’t paired to anything.

Since it’s Zwave, do a general exclusion to exclude it and try again.

1 Like