Ecobee integration no longer lets you select which device for which location

There has been a recent change, that after I connected (again) the app integration, it added all three thermostats (2 at one house, 1 at another) to both SmartThings locations. There used to be the option to select which device, which is no longer there.

The outcome is that all three devices are at both houses. This means, when I’m away from one, and at another, motion sensing from the occupied house is triggering an alarm at the house I’m not at.

After REMOVING the device from the wrong house, the connector is re-adding it every hour.

I’ve logged into SmartThings. Add a little smartness to your things. directly, and added the HUB directly to each device (which was missing). It’s been an hour so far, and seems to be good. Going to give it more time before calling it a successful hack.

They recently killed the Groovy integration and moved to a Schema integration. Ecobee manages teh Schema integration. I would reach out to them and request this functionality be added back. You could also edit the settings in your SmartThings home monitor app so it doesn’t use the motion sensor from the errant thermostat to detect intrusions.

Still happening in case anyone cares

I care because I am experiencing the same issue. Subscribing to learn more.

That would be awesome IF there was a choice to cherry-pick which sensors; it’s all or nothing.