Ecobee thermostats and sensor offline Sept 2021

Sometime around sept 20 2021, all my ecobee devices in two locations went offline. One house has 2 thermostats and 4 sensors the other 1 stat and 2 sensors. I gave it a day or so as others on the ST FB group were reporting a similar issue. Some resolved it ok by re-authenticating. I tried on one house and it gave me an error message. The other house I tried adding a new ecobee device - it prompted me for login, and then re-authenticated and it added those devices back. No go on the other.

Today I resolved to remedy the situation. Tried again with house 2 no go. I went into the IDE for house 2 and behold there were TWO entries for each ecobee device - an older one that was offline, and a new one that said PLACEHOLDER that was online. I tested deleting one of these and then replacing any instances where it was used in an automation with the new PLACEHOLDER. I also use ACTION TILES, WebCoRe, and simple device viewer. I ultimately swapped out all the old instances on house 2 with the new placeholder all seems to be fine now. However, house one still uses the older instance and no placeholder instances were added there. Weird. Anyone posting here in case someone searchs and comes across a similar issue. ST is doing SOMETHING on the backend again that caused this apparently.

A new schema ecobee integration was added several months ago and that’s your placeholder devices. I’m not sure if they migrated existing ecobee devices from Groovy to the schema integration yet. Hard to say who’s at fault. Ecobee definitely had authentication issues that caused the devices to go offline in smartthings. For the location still using Groovy ecobee devices, you should be able to add ecobee in the ST app, get your automations moved over to the new devices and then delete the Groovy devices.

Since the offline issue a few days ago, I can no longer manually control my ecobee thermostat using the control arrows. I get a network error occurred message. It seems to be working when controlled via automations. Any ideas?

Did you go into the IDE and see if you have the two occurances as I described above? Are you able to re-authenticate your ecobee credentials in the ecobee connect smartapp?

Only 1 occurrence in IDE. Its using the new schema. Ecobee is connected and authenticated. It seems to work fine other than loss of manual control in the ST app. Is there an ST Ecobee support person? Direct ecobee support tried to help but wasn’t sure how to proceed with the ST integration.