Echo won't discover devices

Same issue here for both of my smartthings plug outlets.

@cuboy29 @PooBear @MichaelS

Hi guys, please run discovery again on your Echoes and you should see your outlets!

Please confirm that it is now working as expected!


Success! Thanks for the follow up!

Yes! Thanks for the fixing it so quickly!

No problem, sorry about the inconvenience!


I check on this tonight when I got home. While the “Livingroom” in my profile was found, Alexa actually doesn’t recognize the name of it. Let me explain…

In my connected home list, Livingroom is clearly shown now as an active device. I can put it into a group and control it via Alexa. However, if I say ‘Alexa, turn off livingroom’ it says I don’t have a device named that in my profile. I only did a little bit of troubleshooting by completely removing it and re-adding it; it does indeed show me the name (from SmartThings) but it doesn’t understand the actual word I named it. I know the next step is to re-name it in SmartThings and see if it recognizes the new name, but it is getting late.

This is a new problem as "livingroom’ did work prior to this weekend.

Will post more when I have more data…

Edit So, curiosity got the best of me…I renamed the device from Livingroom to Main Room and it worked. I then changed it to Livingroom and it didn’t work. Then, changed it to Living Room, and that DID work. So…my theory is that the Livingroom Sonos name is interfering with the Livingroom name. I will defer to @Lars on why this might be, but it is working now…

The actual speech recognition part is unfortunately all handled by the echo/Amazon so these name misunderstandings are not to much we can do about, expect experiment like you did until you find something that works well. I have also seen people mentioning that sometimes it gets better after a while so there might be some voice training going on in the background as well.

Smart things outlet is not showing up in my list of echo device’s. . Says not in my profile

When I got up this morning my echo was offline and the Alexa app service was down. My internet was fine. After echo came back online it would not recognize my st devices or my wink hub. After a couple of hours everything came back online and now it’s all fine.

I think the problem this morning was on Amazon’s side.

@ryan321 If outlet is working fine from the SmartThings mobile app, make sure that it is checked in the Amazon Echo smartapp before running device discovery again.

Yep I did that but wasn’t working still…must be a problem on amazons side. Smart things app is working fine

I picked up a ST v2 yesterday and was able to easily integrate it with my Echo, and control the receptacle box that came in the kit, and a MyQ wall switch and receptacle box. I was was also able to Open my MyQ enabled Chamberlain garage door opener (still can’t get it to close though)…using Jason Mok’s code via my Echo.

On the heals of things going fairly I went out and purchased a couple of Cree bulbs, a couple of GE Link bulbs, and a GE In-Wall Z-Wave Smart Receptacle today. All of the new devices added pretty easily onto the the ST hub, and all devices can be controlled by the ST Android App. The issue I am having is that none of these are discovered by the Echo App. I’ve searched multiple times, deleted and re-added the devices on the ST hub…and still no dice. I am assuming that I should be able to control these without other hardware, but giving the issues I’m having, I’m not sure what’s up. Any insight would be appreciated.


Welcome aboard! You’ve come to the right place.
In the ST app take a look “SmartApps” tab.
Then click on the “Amazon Echo” app.
Click on “My Device List”
Now, select the devices that you want Echo to control.
Click Next until you reach Done and click on that.
Now, do a discovery in the Alexa App and you should be good to go.

Note Whatever you name the devices in ST is what they will show up as in the Alexa App.
So give your devices natural language names you can remember (and the family can remember). You don’t want to name the Light in the kitchen by the microwave LKM1. I’d call it microwave light.

Also, if you have a bulb or some other device like a Phillips Hue bulb that also connects to its own hub, do not authorize Alexa to see those in the ST app. It will see those items through its own integration with that particular hub. If you click on it in the ST app as well there will be two instances of it in the Alexa app… and that causes all kinds of trouble.

Have fun and don’t worry about asking questions… that’s what the community is here for!


OMG, what a dope I am! Thank you so much Bamarayne.

Now, back to trying to figure out why I can’t get Alexa to Close my garage door… :frowning:

Hey, no problem. That’s a really common oops we all made.

What garage door opener are you using?

It’s a Liftmaster 8500 with the MyQ gateway. I installed Jason Mok’s code, and it is having no issues opening…I just can’t get it to close. Alexa accepts the request and says “ok”…but sadly nothing happens.

On the upside, I installed 5 new GE Smart Switches today (all in one junction box…which let me say was no easy feet to squeeze in), and despite some electrical challenges (I found that I had to connect the white wires to the “Common” terminals on the switches, despite the fact that I simply had them all wire nutted together for the previous switches/dimmers). Once I finally clued in to what was going on (two hours of my life I can’t get back), I had no issues getting them added in ST and working with Alexa.

I had the same problem. The Echo Discover Devices would not add my new Smartthings device so I selected forget all devices and groups in the Alexa app. Now, no Samethings devices are recognized. I do notice that the Smartthings devices in the Echo app shows as my device list as [object Object]. I thought they would have been the Smartthings object name.

Everything was working until I perform this.

The “object, object” is a new problem that occurs when you try to link a third party account like Echo or Harmony. Just started a few days ago. Doesn’t affect devices already authorized.,_object_instead_of_device_name

I am having the exact same issue. It started with Echo not being able to control devices. So I unlinked and now I can find devices when I relink, but they cannot be discovered via the Alexa app or when I ask Alexa directly. I have restarted everything.

I am having the exact same problem. alexa was having trouble with some devices so I unplugged it and then asked her to find my devices. she responded none could be found. She was able to control some that she had found previously. Tech support at Amazon suggested I forget all the saved devices. That was a mistake because she no longer finds any devices and has nothing saved to fall back to. Tech support says they will escalate this to the next level and will call me back within two days. So for now I have 25 devices that worked yesterday using echo and none today. I have a mixture of Belkin wemo and Phillips hue. None of which can be found. NO router upgrade or power outage. I wonder if they pushed a firmware out that broke discovery?
All my devices work using the Belkin and Phillips Hue apps as does Wemo Manager from the play store.