Echo won't discover devices

Hey guys,
First want to say that the SmartThings integration with echo is awesome, and everything has gone very smoothly up until today when I ran into my first major issue. I installed a new st device and was attempting to integrate it with echo when I realized that all my devices were showing as “offline” in the Alexa app. I cued echo to turn on the lights, and it worked, but it still wouldn’t find the new device. I decided to use the “forget all devices” option as well as the “forget connected home options” and then re-add devices. Now to my chagrin I’m finding that I can’t add any devices at all, from the alexa app, or from telling echo to search for new devices verbally. I’ve since unlinked and re-linked st from the alexa app, restarted the internet, restarted the st hub, restored factory settings to echo, tried authorizing individual devices only, all with no luck. My devices however are all responsive through the st app. Anyone run into anything similar yet or have any suggestions for what might be causing this problem? Thanks!

Report it to

My Echo integration blew up this morning. I am very depressed.

Echo still works for now. But everything else is blowing up. Ever since server maintenance I’ve been having nothing but problems. Actually looking forward to tearing everything apart and putting it on V2 because nothings working on V1 right now. First time I’ve ever had to put back to back incident reports in.

An unrelated change introduced an issue into the Echo discovery mechanism. It’s fixed now - sorry for the trouble!

Have you contacted support? They can escalate the issue.


Thanks, confirmed working. You guys are awesome.

My problem is fixed as well, all the devices now have the device types that they should and my echo integration is working again. :sunglasses:

1 Like

Something has changed since last Week, although I don’t know whether it’s on the echo side or the smartthings side.

Echo now identifies my zigbee plug-in modules as “outlets” rather than “switches.” It also says all of these are “off-line” and will not operate them.

Again, this is a change, I was using the same switch on the first day the smartthings integration was available and it worked fine through echo then.

Similar problem here…did the discovery and it won’t find any of the Zigbee plug in (SmartThings) outlets. All other Zigbee, ZWave and other ZigBee type devices were found ok. Very strange…any insight @Tyler?

Support just let me know they’re aware of the problem with devices classified as “outlets.” They suggest using a virtual switch for Echo for the time being.

Good to know…I am going to start looking at developing some apps for this using the virtual switch scenario…I can already see ‘macros’ being set up that will do all kinds of things I have now set to remotes.

Set up a simulated switch, used “the big switch” to slave the real zigbee plug to it, authorized echo to use the simulated switch, and that’s all working well.

Meanwhile, one of the ST engineers says it will be fixed tomorrow. :sunglasses:

1 Like

Did something happen again with the discovery of socket switches? My echo had to do a re-discovery and now the plug-in sockets are not seen again.

edit…now it is working…things appear a wee unstable this morning :frowning:

Upon going to version 2 of the hub (which seemed to migrate ok with all of my devices, sans a couple minor items), I did notice sockets are not recognized again. @Tyler is this still a known issue? Did contact support about it, but was curious if anyone else is noticing this. It worked Friday with no problems.

Hey Michael!

Support should be able to help you. I’m not aware of any ongoing issues.


Opened a ticket yesterday…Thanks.FYI, it is still an issue as of an hour ago.


Still unable to do this. I believe the support person I was working with is on the weekend shift, so I am not sure this will get the visibility it needs. As of this morning I am still missing the outlets from the Echo discovery. Thinking about this more, is this a SmartThings issue or more with Amazon?

It’s a smartthings issue because somehow smartthings has changed the device type on the platform side.

This is happened to me multiple times with the same device, when I made no changes at all.

Amazon echo only views certain types of devices as controllable. These are basically lights and switches.

It appears that smart things is using a device class of “outlet” instead of “switch” for these plug-ins, and that’s causing the problems.

If I go into the IDE and change the device type to zigbee dimmer, echo has no problems finding it. It shows up as “outlet (dimmable)” and echo can then turn it on or off or dim, no problem.

@MichaelS Sorry that you are having issues with Echo, let me see if I can help.
Can you confirm that the outlets your are using are the SmartThings SmartPower Outlet hardware as well as using the default device type?
Also, can you confirm that the devices work fine from the SmartThings app but show up as offline in the Amazon Echo app?


Yes to both of your questions…I re-set these up in my new v2 hub and they work as expected via SmartThings. The issue is when I attempt to ‘discover’ them with Alexa. She sees the info coming from the app, it just shows the device ‘offline’

Let me know if I can provide additional information.


I might be having the same issue.

V2 hub with SmartPower Outlet, works fine in SmartThings app. Also works with Echo on initial discovery, but goes “offline” after 30 mins or so.

The only way I can get it to show up online again is to completely remove the Outlet from both the Alexa and SmartThings apps, then discover and add it again in both. Then it works for another 30 mins before going offline again. I ended up using a virtual switch as a workaround.