Echo turn Hue light on....in a dimmed state?


(John) #1

Has anyone seen this issue? I have a few Hue lights around the house. I have the Hue bridge set up to work directly with Alexa. It is also paired with Smartthings.

At times, if I say “Turn on the living room light,” it will turn the light on, but only at about 25% brightness. However, it was at 100% brightness when I turned the light off…?

I do have two virtual switches in ST so I can do things like “Turn on Goodnight,” which runs a routine and shuts off all the lights. Or “Turn on TV mode” which shuts off all lights except the living room.

I use the “Goodnight” every night before bed. I also almost always use the “TV” mode switch.

For some reason, within the last two-three weeks, Alexa is now not turning the living room light on at 100% any more. I’ve had the Echo since December of 2015 and I NEVER had to tell it to turn on at 100%. A simple “On” command would return it to it’s last state.

I’m trying to figure out if the ST virtual switches is screwing this up some how…Has anyone else seen this behavior?


#2

I think this behavior is a bug with Alexa. It has been persistent for a while.

I get around it by making rules in Rule Machine that state that if a specific bulb is turned on to always set the brightness on it 100%.


(Jason "The Enabler" as deemed so by @Smart) #3

Are your bulbs ge link bulbs?

If yes, this is a bug in the firmware of the bulbs.

If they are actually Phillips hue bulbs, this is the first I’ve heard of that. None of mine do that.


(John) #4

@bamarayne 100% Philips Hue bulbs…those are the only smart bulbs I have in the house.

@bobfather interesting thought. I may try that. Honestly, this only hit me about three weeks ago. I’m not sure if it has anything to do with the Virtual Switches I created…I guess I can always try live logging…it’s just tough as it’s not every time I turn the light on.


(Jason "The Enabler" as deemed so by @Smart) #5

That’s a new one on me. off I’ve only seen this with ge GE bulbs.

I also do what @bobfather does for my GE bulbs.


(John) #6

I did some testing last night…

If I say “Turn on the Living room light,” which is native Alexa > Hue, It turned on at 25%.

If I say “Turn on on TV Mode,” (a VS in ST that turns off lights and turns on my living room light) which is Echo > ST virtual switch > Hue, it works fine, 100% of the time.

Therefore, it’s not because of the intermediary of ST but rather a bug between Alexa and Hue itself, is my guess.


(Realy Living Dream) #7

Stupid suggestion, but you wouldn’t happen to have a setting in Good night to set dimmers to __% ? I found that all my Hues were seemingly always coming on dimmed. Not only with Alexa, but also with other triggers/automations. Having basement lights come at at 10% is just asking to trip over something.
I realized that part of my GoodNight routine was to set dimmers to 10%. I ( wrongfully) assumed this would only effect the outdoor GE lights that are actually on at night.
Once I removed the " set dimmers to 10%" from GoodNight, Hues went back to coming on at the last state.


(John) #8

Thanks for the suggestion…I just checked and there was nothing set for “Set dimmers to…”

However, you gave me an idea…what if I set this to 100%? Will this turn on the lights after they’re turned off? Or will it just set the system to show the dimmer @ 100%? If so, I wonder if this is an easy “reset” of sorts…


(John) #9

So this just happened again and I figured it’d be a good idea to grab some live logs! Hopefully someone can maybe shed some light and dig down to why this is happening?

The files are linked in dropbox…

Turn_On_LL = Telling Alexa to turn on Living Room Light directly - This is what fails…

Turn_On_TvMode = Telling Alexa to turn on a virtual switch which turns off all lights but turns on the living room light. This works 100% of the time.

Thanks!


(John) #10

So…many months later, I was just hit with a “Hmmmm” moment.

As my 4 month old daughter was sleeping, I wanted to turn the lights on, but not to 100%. So for basically the first time ever, I used the Hue app to turn on the light. I opened the Hue app, hit the toggle switch for the living room lamp and sure enough, it came on at the dimmest possible state.

As most probably know, Hue bulbs will turn back on to their last “live” state before they were turned off.

Every night, everything is shut down with a Good Night routine. Therefore, I’m now nearly 100% positive, the Good Night routine is causing this to happen, as @RLDreams suggested. The weird thing is, it only happens with my living room lamp AND I see nothing about dimming in the routine.

Just figured I’d update this thread with my findings!

[EDIT] I’m going to expand on this since once I start digging, I can’t stop! It is NOT the Good Night routine. I created a test routine and it did the same thing. I then tried turning the Hue light on to 100% via the Hue app, I went into the ST app, and turned the bulb off from the “Things” page. Lo’ and behold, it turned on dim. Therefore, it doesn’t appear to be routine based but rather ST based.

Now, I am using a third party SA for the Hue bulbs. Time to go back to the native SA (not going to be fun) and do some more testing.


(Jason "The Enabler" as deemed so by @Smart) #11

Actually, when you are turning on a dimmable bulb in the smart app, either ST or Hue, if you tap at the far left end of the bar it turns on a dimmed stated… tap anywhere on that bar and it turns on at that respective percentage.


(John) #12

Correct, what I was explaining was in regards to just toggling the tile On/Off


(David) #13

I just test this.

Saying Alexa, Turn the [Room Name] Light on at [Dim Value] Percent, works.

The Hue hub remember the state the light was turned off at and turn it back on to the same state unless told other wise

My Hue bulbs are connected directly to the Echo, not passed through SmartThings, when using the Echo


(Jason "The Enabler" as deemed so by @Smart) #14

Not saying you’re wrong…

But your hue bulbs are connected to your hue hub, which is integrated cloud to cloud with your echo.

Echo does not remember what state the bulb was last in, not dies it know what state your bulb is.

If your bulb is on and you tell Alexa to turn it on, it will send a turn on command to your hue hub and echo will say ok. The hue hub knows that your bulb is on and acts accordingly.

The hue hub knows what the current state and level your bulb is at ST and turns it back on at that level unless directed otherwise.

You are correct about the bulbs not passing through the ST hub when using your echo. That is one of the great things about the echo integration and the way the hubs work together.


(David) #15

Very true. I will correct what I said.

It appears that know SmartThings Device Handler knows the last state of the light.

I just tried a bunch of tests and each time the light come back on to it’s last know setting.

using Echo, Hue App, and SmartThings.

Also when did SmartThings add White Color Temp to their device Handler??!?!