Amazon Echo Turning On Lights at 25%

amazon'alexa'echo

(Jeremy Carrigan) #1

I have all kinds of GE Link bulbs that I use with Smartthings and they work really well with the “My GE Link Bulb v2” Device Type. One issue I’m having however is that when I use my Amazon Echo to turn these lights on, she only turns them on with 25% brightness. I then have to tell her to adjust the brightness to 100%. Has anyone else seen this issue?


(Scott G) #2

I haven’t seen this in my own experience. Is it possible that the last dim setting for the GE Links was 25%? The GEs will turn on to the previous dim level when receiving an on() command. If you never really set them to 25%, I would try checking the logs to see what command the Echo is telling ST to send. (Live logging is in the IDE, accessed through the developers area of ST website, just login/signup at top right after getting to developer page).


(Dan) #3

Our Echo also turns on the GE Link lights at a lower level than 100%. Since we almost exclusively use the Echo to control the GE Link lights, I don’t think it’s an issue with the lights having been set lower, previously. We almost never dim them. I wouldn’t say ours is as low as 25%, but I haven’t checked the SmartThings app to see exactly what the level is. They do go noticeably brighter when I ask Alexa to dim them to 100%.


(Jason "The Enabler" as deemed so by @Smart) #4

I have over 20 GE Link bulbs that I use almost exclusively with Echo. They are all connected to my ST hub. Every one in a while I will find a light that doesn’t light up to 100%. But that is maybe once a week. Not enough to be annoying at all.

I am using the Native GE Link device type that was already in the API.

You could possibly try deleting the custom device type and using the native one.

I’ve had really good luck with it.


(Jeremy Carrigan) #5

Thanks for all the responses and suggestions. I have currently switched from my custom device type to the native one. I am still seeing the same issue. When ever I turn on the GE Link lights using Alexa they turn on and then dim to 25%. I’m going to open a case with ST support.

I did see this in the logs for one of the bulbs when I use Alexa to turn the light off, and then back on again:

2015-11-01 9:00:43.918 PM EST
5 minutes ago DEVICE switch.setLevel 25 Bar Light 1 set level is 25
2015-11-01 9:00:38.498 PM EST
6 minutes ago DEVICE level 25 Bar Light 1 level is 25
2015-11-01 9:00:38.467 PM EST
6 minutes ago DEVICE switch on Bar Light 1 switch is on
2015-11-01 9:00:24.482 PM EST
6 minutes ago DEVICE switch.setLevel 0 Bar Light 1 set level is 0


(Jason "The Enabler" as deemed so by @Smart) #6

Try this… it’s worked for me when my lights weren’t turning on right…

Open the individual light in ST app. Set the percentage to what you want. (try 99% instead of 100% ~ not sure why this works better).

Then click refresh slowly 3 or 4 times… and when I say click… click and hold a second and do that several times each.

I’ve had good luck with that working.


(Scott G) #7

Good idea opening the case with support. This looks like an issue with the Echo integration. If you just tell Alexa to turn on/off, then you shouldn’t see setLevel entries in the logs at all. It looks like when turning off its sending the level to 0, which isn’t good either.


(Jason "The Enabler" as deemed so by @Smart) #8

Have you tried what I posted above?


(Jeremy Carrigan) #9

I haven’t yet. I will definitely try it when I get home Jason. Thanks.


(Jeremy Carrigan) #10

Jason I tested this just now and unfortunately still experiencing the same issue. Hopefully support will get back with me soon.


(Jason "The Enabler" as deemed so by @Smart) #11

Dang, sorry to hear that.


(Realsol) #12

@NeverOne99, any word from support on this. I am experiencing the same with my GE Lights. My log looks just like yours. Funny though, I didn’t notice this last week. Seems to have started with my last Android update. Support told me they release a new Android version yesterday, though it must be held up by Google.

Let me know if you hear anything. Thanks.


(Jeremy Carrigan) #13

Sorry but I haven’t heard anything from support. I will email them again.


(Realsol) #14

@NeverOne99, I have been testing my Bedroom GE Links this morning. If I toggled the bulb off from within the Android app, I see in the log that the ‘Set Level 0’ is being sent to the bulb. When I toggle it back on, it is dim, not 100%. This might not be a Echo issue.


(Scott G) #15

What device type are you both using? Stock? Can you check the device page in the IDE to verify?

I checked the stock device and it should be sending a simple off() command, so maybe it’s an Android bug.


(Realsol) #16

@Sticks18, I am using the stock ‘GE Link Bulb’ device type with Android App, although like @NeverOne99 stated, this happens when triggered also by Echo (virtual switch), or in my testing, just clicking on it within the Android App.


(Jeremy Carrigan) #17

I heard back from ST support and they said the proper way to operate the bulbs is to say “Alexa turn on (light name) to n%.” I have tested this and it does work.


(Jason "The Enabler" as deemed so by @Smart) #18

I’ve never had to do that… It usually turns them on at whatever the last setting was.


(James) #19

Wow is this confusing. It’s as though there is a default 25% level set for dimmer devices that gets sent for Alexa dimmer “on” requests unless you (magically?) mess with the dimmer level enough to get rid of it.

I’m using the Echo with my own lighting integration and can literally see my Echo “on” requests change from “setLevel” requests to “on” requests after fiddling with the loads level a bit. No idea why…


(Travis) #20

I’m controlling 2 GE link bulbs with the echo snd haven’t had any issues. I usually run mine at a lower level anyway so if they do come on at a lower level, it doesn’t bother me.